PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Web-Unterseite mit Passwort schützen



Peter K
21.01.2003, 17:00
Hi Leutz,

ich hab ein kleines Problem: der Passwortschutz einer Unterseite funktioniert nicht mehr?! Ich bekomm den nicht mehr zum Laufen.

In der Root ist die Datei .htpasswd, im zu schützenden Ordner die Datei .htaccess ...

Was fehlt/ ist falsch und wo pflege ich die PW?

jwl
21.01.2003, 17:56
hallo peter

du hast das verzeichnis umbenannt?
wenn ja dann musst es in der ht... auch ändern

gruss jwl

Peter K
22.01.2003, 07:22
Moin Johannes

Ne, hab eigentlich nix verändert, wenigstens net bewußt!

Habe dann mit einem Generator neue gemacht, die funzen auch net. Strato hat ein CGI dafür, aber net für Frontpage, die schreiben dort, man soll den FP-eigenen Generator verwenden. Den kann ich aber nicht aktivieren (Extras -> Sicherheit läßt sich net anwählen ...).

HMMM, irgendwas mach ich falsch! Aber was?

stephan
22.01.2003, 13:12
Hallo Peter,

wenn du den apache als www-server benutzt kannst dass Passwort mit htpasswd von der shell aus bearbeiten. Genaue Infos dazu bekommst du aus den man-pages oder such einfach mal bei google nach htpasswd + apache. vielleicht hilft Dir auch das hier:

a0520@campfire$ man htpasswd
Reformatting page. Wait... done

User Commands htpasswd(1)

NAME
htpasswd - Create and update user authentication files

SYNOPSIS
htpasswd [ -c ] passwdfile username

DESCRIPTION
htpasswd is used to create and update the flat-files used to
store usernames and password for basic authentication of
HTTP users. Resources available from the httpd Apache web
server can be restricted to just the users listed in the
files created by htpasswd. This program can only be used
when the usernames are stored in a flat-file. To use a DBM
database see dbmmanage and dbmmanage.new.

This manual page only lists the command line arguments. For
details of the directives necessary to configure user
authentication in httpd see the Apache manual, which is part
of the Apache distribution or can be found at
http://www.apache.org/.

OPTIONS
-c Create the passwdfile. If passwdfile already exists, it
is deleted first.

passwdfile
Name of the file to contain the user name and password.
If -c is given, this file is created if it does not
already exist, or deleted and recreated if it does
exist.

username
The username to create or update in passwdfile. If
username does not exist is this file, an entry is
added. If it does exist, the password is changed.

SEE ALSO
httpd(8)

SunOS 5.6 Last change: February 1997 1

gruss
stephan

stephan
22.01.2003, 13:19
Hallo Peter,

mir faellt da noch was ein, es ist unbedingt notwendig, dass sowohl die htaccess als auch die htpasswd Datei für ALLE lesbar ist. Die Zugriffsrechte kannst du normalerweise in Deinem FTP-Programm mit dem Befehl CHMOD oder Zugriffsrechte instellen. Das Datei-Attribut für die beiden Dateien sollte so aussehen -rw--r--r--.

gruss
stephan

Peter K
24.01.2003, 07:53
Hoi,

der SCH**SS geht immer noch net ....

die Zugriffsrechte hab ich kontrolliert, sind richtig (unter wsftp_pro unter Info).

Das Passwort wird einfach net akzeptiert. Habe es mit verschiedenen Generatoren erstellt, jedensmal das gleiche -> nach dem 3. Versuch "Authorization Required
This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required." :(

Kann das ein Strato-Problem sein? Denn wenn ich die .htaccess nicht über deren cgi mache, kommt die o.g. Fehlermeldung sofort, bevor er den Benutzer anfragt.

[ 24. Januar 2003, 08:31: Beitrag editiert von: Peter K ]

AchimS
24.01.2003, 11:11
Was mir noch einfällt: Du brauchst den Pfad in dem Deine Webseite liegt, damit der Server das richtig verarbeitet. Bei 1&1 erzeugen sie die htaccess Files über ein Frontend, das bastelt den dann passend rein.
Das Problem ist, daß Du normalerweise nicht weißt, wo im Filesystem das Root Deiner Website liegt. Es sei denn Du hast nen shell Zugang oder es ist dokumentiert...

Achim

stephan
24.01.2003, 16:07
Hallo Peter,

wie sieht denn Deine .htaccess aus?
ich habs eben mal bei meinem strato Account nachgeschaut und da sieht sie so aus:


AuthUserFile /home/strato/www/he/www.heider-online.de/htdocs/.htpasswd
AuthGroupFile /dev/null
AuthName Intern
AuthType Basic
<Limit GET>
require valid-user
</Limit>
und die zugehörige .htpasswd stehen nur die erlaubten Benutzer + das verschlüsselte Passwort. Sie sieht dann so aus:



Administrator:abIzNiew9jKVs
upkm:ab325gYweN2/MvI
Erzeugt habe ich die .htpasswd unter linux mit dem entsprechenden tool.

gruss
stephan

Peter K
24.01.2003, 20:19
JUP,

es geht wieder. Hatte Strato angemailt, die haben mir dann den link zum Strato-Generator geschickt. Das Problem war wohl, dass das cgi das Passwort anders verschlüsselt als die html-Generatoren ....

Danke für eure Hilfe!