PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : MWC Probleme



Feuerstein
01.05.2011, 19:50
Hallo zusammen,

ich hab mir auch einen MulitiWiiCopter angeschafft (Danke Sven....).
Nur komme ich leider nicht klar.
Habe nach Anleitung den Empfänger installiert (Kanäle 1-4, den 5. Kanal auf einen Schalter, neutral).
Zur Kalibrierung gebe ich TROTTLE nach unten, YAW links; sowie Pitch (Roll beim Heli) nach unten.
Die LED auf dem Board blinkert eine weile und geht dann wieder aus.
Nur die Motoren lassen sich anschließend mit THROTTLE auf unten (min) und YAW rechts nicht starten?
.... das ist mein erstes Problem.
Mein Zweites ist, das das Konfigurationsprogramm "MultiWiiConf1_prebis7" unter Linux startet, nur die Schnittstelle zum mit dem PC verbundenen MWC nicht findet? So kann ich nicht mal sehen, ob die Fernsteuerung mit dem MWC richtig arbeitet.

Wie komm ich jetzt da weiter?

Gruß
Fred

capriolo
01.05.2011, 20:21
Hi Fred,

das liegt oft an zu gringen Servowegeinstellung.

Hast du die Servowege bei deinem Sender auf max. Wg eingestellt (120%) ?

Damit müsste der copter dann aktivierbar sein.

Zu linux kann ich nichts sagen. Bin microsoft geschädigt :D

LG Christian

Feuerstein
02.05.2011, 08:20
Hallo Christian,

der Tip hat geholfen (+/-120% je Kanal symetrisch), ich bekomme die Motoren eingeschalten.
Jetzt habe ich am Sender die Einstellungen etwas geändert,
2 Kanäle musste ich invertieren, so das die Einstellungen stimmen.
(YAW und ROLL)
So war ich heute morgen schon in der Luft, hurra er fliegt.....
So bleibt mein 2. Problem noch offen, das Konfigurationsprogramm.

Gruss
Fred

Wolfi
02.05.2011, 12:31
Hallo Fred,

welches Linux verwendest du? Es funktioniert bei mir mit Ubuntu 10.4 und Debian-6 64bit.
Versuch mal

cd /lib/modules/<kernelversion>
und
find . -name "ftdi*"

Dort muss irgendwo der ftdi treiber liegen.


/lib/modules/2.6.32-5-amd64$ find . -name "ftd*"
./kernel/drivers/usb/serial/ftdi_sio.ko
./kernel/drivers/usb/misc/ftdi-elan.ko


Grüße
Wolfgang

Feuerstein
02.05.2011, 17:44
Hallo Wolfgang,

ich verwende SUSE 11.3
die beiden Dateien habe ich gefunden:
file:///lib/modules/2.6.34.8-0.2-desktop/kernel/drivers/usb/serial/ftdi_sio.ko
file:///lib/modules/2.6.34.8-0.2-desktop/kernel/drivers/usb/misc/ftdi-elan.ko

Kann ich da noch etwas einstellen?

Wenn ich auf PORT COM im Konfigurationsprogramm drücke, wechselt das Zeichen dahinter von "-" nach "+", und beim zweiten mal wieder zurück.

Die Schnittstelle zum Arduino, inkl. Kabel ist in Ordnung, habe die *.pde Datei kompilieren und auch zum MWC fehlerfrei übertragen können.


Grüße
Fred

Wolfi
03.05.2011, 08:42
Hallo Fred,

hmmm, seltsam. Wenn die Schnittstelle zum Arduino funktionert....

Versuch mal folgendes:

Wenn das Kabel nicht angesteckt ist sollte der Treiber auch nicht geladen sein.

wolfi@piper:~$ lsmod | grep ftdi

Dann das Kabel mit dem FTDi breakout board anstecken.
Die Treiber sind das geladen:

wolfi@piper:~$ lsmod | grep ftdi
ftdi_sio 30070 1
usbserial 33357 3 ftdi_sio

Jetzt sollte es in /dev ein ttyUSB device geben

wolfi@piper:/dev$ ls -l /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 2011-05-03 08:26 ttyUSB0


Beachte die Berechtigungen. Wenn du nicht unbedingt als root arbeitest, dann must du in der dialout gruppe sein:

wolfi@piper:/dev$ id
uid=1000(wolfi) gid=1000(wolfi) groups=1000(wolfi),4(adm),20(dialout),24(cdrom),46(plugdev),111(lpadmin),119(admin),122(sambashare)


Ach ja... zuerst das Kabel anschliessen, dann da GUI starten, sonst wird die Schnittstelle auch nicht erkannt.


Grüße,
Wolfgang

Feuerstein
03.05.2011, 10:43
Hallo Wolfgang,

da sind wir schon auf dem richtigen Weg.
Unter Root funktioniert es....
Leider läuft auch das Ardiunoprogramm nur unter Root in der Kommandozeile.
Das soll aber eine andere Baustelle sein.

Habe mich jetzt in die Gruppe dialout eingetragen, trotzdem funktioniert das Konfigurationsprogramm nicht. Die Schnittstelle wird nicht angezeigt, wie unter Root.
Wobei unter Root eine zweite vorhandene Schnittstelle, TTS4, angezeigt wird.

Hier mal die Einträge der Kommandozeile:
papa@linux-t510:~> lsmod | grep ftdi
ftdi_sio 35483 0
usbserial 34513 1 ftdi_sio
papa@linux-t510:~> ls -l /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 3. Mai 10:38 /dev/ttyUSB0
papa@linux-t510:~> id
uid=1000(papa) gid=100(users) Gruppen=5(tty),16(dialout),33(video),100(users)
papa@linux-t510:~>

Gruß
Fred

Feuerstein
03.05.2011, 12:59
Hallo Wolfgang,

es funktioniert.
Habe die Gruppen UUCP, LOCK und DIALOUT meinem Account zugeordnet.
Jetzt geht auch das Arduinoprogramm mit meinem Zugang, nicht nur unter Root.

Nun muss ich mal sehen, wie ich Parameter ändern kann, um den MWC anzupassen.
Momentan fliegt er wie ein großer (viel zu-) träger Modellheli.

Danke
und Gruß
Fred

capriolo
03.05.2011, 20:10
Ich habe die CAMSTAB aktiviert und es funktioniert auch.

Das angeschlossene Servo steht in Mittelstellung und der Ausgleich beim Neigen des copter wird korrekt durchgeführt.

Ich möcht nun aber die Schwenkstellung des Servos über einen zusätzlichen Kanal(z.b. K6)
ändern.
Was muß ich dazu im code noch aktivieren? Oder gibt es diese Funktion noch nicht?

Christian