PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : M-Link Telemetrie RPM Sensor an Tachoausgang Zündung - Problem



Volcom-
30.12.2014, 23:43
Hallo zusammen,

da die Frage doch relativ spezifisch ist, ist sie wohl in dem "Bastlerbereich" hier im Forum am besten aufgehoben.

Kurz zur Erläuterung:

In meiner Krill Extra betreibe ich eine Powerbox, Empfänger und Servos auf 5,9V.
Die Zündung (DLA 64) wird direkt über einen Powerbox Zündschalter von einem 2S Lipo gespeist.

An dem RPM/Tachometer-Ausgang der Zündung greife ich das Drehzahl Signal nur mit einer Litze (orange) ab und führe es auf den Drehzahleingang Signal des M-Link Drehzahlinterface.
Das funktioniert (bisher Kurbelwelle von Hand gedreht, Drehzahl wird übertragen).

So wie auf dem Beispielbild, nur ists bei mir im Moment nur die Signalleitung:

1277729

Nun das eigentliche Problem, bzw. die Fragestellung:

Das Potenzial des Drehzahlausgangs der Zündung sollte ja eigentlich der Spannung des angeschlossenen 2S-Zündungsakkus entsprechen, oder?
Das heißt, das Potenzial des Impuls welcher zum Telemetrieinterface gelangt entspricht 7,4V...wobei das Interface an 5,9V (Empfänger) hängt. Also bekommt der Empfängerstromkreis doch bei jeder Umdrehung einen Spannungspeak ab, oder?

Habt ihr da Ideen, Vorschläge, ist mein Gedankengang richtig oder falsch? Gibts potenzielle Probleme?

Bin für jede Hilfe dankbar,

Grüße Daniel

Hupf
30.12.2014, 23:55
Hallo Daniel,

Genau das selbe habe ich vor ca. 1 Jahr bei Multiplex angefragt (an einer DA-Zündung, ohne diesen speziellen Ausgang), mir wurde dringend von dieser Lösung abgeraten, da sich so Störungen ins System einstreuen können.

Dein eigentliches Problem ist aber gar nicht existent, da der Sparkswitch intern die Ausgangsspannung auf 5,9V regelt: https://www.powerbox-systems.com/de/produkte/zubehoer/schalten-und-regeln/sparkswitch.html

Grüße,
Fabian

Volcom-
31.12.2014, 00:02
Hallo Fabian,

Dann kann ich mir dir Anfrage bei Multiplex wohl sparen.
Mein Zündschalter ist die 7,4 V Variante ;)

Gibts jemanden der sich mit Optokopplern auskennt?

Grüße aus Ehingen ;)

Hupf
31.12.2014, 00:08
Pardon, ich wusste gar nicht, dass es mittlerweile eine HV-Variante gibt!:rolleyes:

Roland Schmitt
31.12.2014, 00:31
Seid ihr euch sicher? Der Meßeingang am Sensor müßte doch entkoppelt und relativ hochohmig sein. Es sollte dort auch keine Spannung anliegen, sondern ein Impuls. Ich hätte das jetzt eher so verstanden das man nicht direkt den Zündimpuls abgreifen darf, was ja die einzigste Möglichkeit wäre wenn die Zündung keinen Ausgang hat. Insofern hat das mit der Spannungsversorgung der Zündung nicht zu tun.

Volcom-
31.12.2014, 01:39
Seid ihr euch sicher? Der Meßeingang am Sensor müßte doch entkoppelt und relativ hochohmig sein. Es sollte dort auch keine Spannung anliegen, sondern ein Impuls. Ich hätte das jetzt eher so verstanden das man nicht direkt den Zündimpuls abgreifen darf, was ja die einzigste Möglichkeit wäre wenn die Zündung keinen Ausgang hat. Insofern hat das mit der Spannungsversorgung der Zündung nicht zu tun.

Hallo Roland,

ob der Messeingang entkoppelt ist weiß ich nicht. Der Impuls selbst hat aber auch ein Potenzial, oder? Im Moment habe ich am Messeingang auch nur die Impulsleitung angeschlossen, da ich eben fürchte dass Empfängerkreis und Zündungsausgang unterschiedliche Spannungen haben. Es geht also jetzt nur um das Potenzial des Impuls und das Störpotenzial.

Werde da wohl bei Multiplex anrufen müssen.

Grüße

Hans-Jochen
31.12.2014, 08:37
Hallo Daniel,

deine Schaltung Post#1 findest oder hast du bei/von der MPX-Service-Seite. Da wird lediglich darauf hingewiesen, dass die Belegung des Tachoausgangs beim Hersteller der Zündung zu erfragen ist.

Ich bin an dem gleichen Problem dran. Bei Zündungen mit extra Tachoausgang hat man vermutlich das Signal vom Hallsensor der Zündung am Motor auch direkt zusätzlich zur Verfügung gestellt. MPX arbeitet im Empfänger Bereich und M-Link ja auch im HV-Bereich, somit dürfte der Spannungsunterschied bei Zündungen mit Lipos kein Problem sein.

@Fabian:
Falls eine Zündung keinenen separaten Tachoausgang verfügt kann ich mir nicht vorstellen wie man eine Signalkopplung, ohne in die Schaltung einzugreifen, bewerkstelligt. Hier würde ich zur Sicherheit den M-Link- Drehzahlsensor zusätzlich montieren.

Mein Teststand ist betriebsfertig und sobald ich endlich den Stuhl Motomix habe kann ich berichten.

http://www.rc-network.de/forum/showthread.php/489879-Saito-FG21-Z%C3%BCndung-mit-Drehzahlgeber

Hans-Jochen

Roland Schmitt
31.12.2014, 09:09
Hallo Daniel, ja im Prinzip meinte ich das, wenn natürlich Meßeingang und Sensoranschluß das gleiche Potential haben geht das sowieso nicht. Was mich irritiert ist das Anschlußschema. Auf dem Bild wird ja der "rote" Anschluß als GND benutzt.
Wie funktioniert das überhaupt mit der "magentichen" Messung? Wird da eine Spannung induziert, oder ist der originale Messaufnehmer ein Schalter?

Volcom-
31.12.2014, 12:24
Hallo Roland,

Fragen über Fragen...gibt's da keinen von MPX der hier mitliest?


Hallo Hans-Jochen,

mein Problem ist nicht dass das M-Link Modul die 7,4V nicht vertragen könnte, sondern dass bei jedem "Klick", bzw Impuls der Zündung, ein höheres Potenzial auf den Empfängerkreis gegeben wird als die Servos vertragen. Der Empfängerkreis läuft mit 5,9V.

Grüße

Hans-Jochen
31.12.2014, 15:01
Hallo Daniel,

der Spannungspeak aus der Zündung wird in der Sensorschaltung von einer Transistorschaltung an die Versorgungsspannung im Empfängerkreis angeglichen oder bzw. verstärkt (je nach Signalpegel).
Deshalb wird auch nur zusätzlich die Masse (Minus) auf den Sensorkreis gelegt.
Wenn bezüglich der Anbindung seitens MPX Bedenken bestünden, hätten sie die Schaltung nicht im Servicebereich veröffentlicht.

Hans-Jochen

DSLMatze
05.01.2015, 19:18
Moin,

klemm ein Rcexl Speed Signal Optical Isolation Unit (http://www.hobbyking.com/hobbyking/store/__56128__Rcexl_Speed_Signal_Optical_Isolation_Unit.html) zwischen Zündung und MPX-Sensor , damit hast du eine Trennung.

Habe so ein Teil von Graupner zwischen RPM-Signalausgang der Rcexlzündung und HoTT Air-Modul, funzt 1A.


Matthias

Hans-Jochen
06.02.2015, 13:55
Wie versprochen kann ich berichten.

Ich habe jetzt den Sensor-Ausgang der Zündung nach der Multiplex Empfehlung (Bild in Beitrag #1) mit dem RPM-Sensorbaustein getestet. Anschluss erfolgte wie im Bild:
- Oranger Draht des RPM-Tacho Ausgangs auf gelb vom Sensorbaustein
- brauner Draht auf Rot (ist zwar verwirrend, aber passt so)

Man kann es testen ohne Motor anzulassen, muss aber die Zündung dazu einschalten und den Magneten mit der Kurbelwelle über den Sensor hin und her bewegen. !!!! Kerzenstecker dazu ziehen !!!!

Anschließend habe ich meinen Saito FG21 einlaufen lassen - Drehzahlmessung funktioniert prima.
Den Sensor kann ich anderweitig fest einbauen und bei Bedarf nur noch den Sensorbaustein tauschen.

Hans-Jochen