Alternative zu WinPC NC?

Ich habs satt!!

Heute zum wiederholten male hat Winpcnc Amnesie und mal so locker alle Parameter vergessen! Fräse läuft los um dann zwanglos mit 13 mm "Z" Zustellung in die Opferplatte zu rasseln! Fraäserbruch und Werkstück hin. Wohlgemerkt, vorgestern noch ganz brav normal gefräst. Also quasi nach dem neue Rechner einschalten.

Ich würd ja noch an mir zweifeln wenn das jetzt nicht ein paar mal passiert wäre! Parameter für die Maschine werden nur sporadisch gespeichert, dazu muß man Winpcnc evtl. zwei, dreimal neu starten und jedesmal neu einstellen.
Ich finds echt übel das die Software so dermassen lausig programmiert ist und man dafür doch ne Stange Geld abgeben muß!

Wer also eine Winpcnc Economy von mir haben will kann diese jetzt günstig haben.

Allein die Alternative fehlt mir! Was gibt es sonst noch das grafisch orientiert arbeitet??

Andreas
 
Also ich bin mit der inzwischen kostenloser Version von EAS "NC Start 3.5" bestens zu frieden. Ich habe sie für meine Fräse schon Jahre.
Gruß Thomas
 
Mach3 direkt bei Artsoft und dann die deutsche Selig-Oberfläche dazu.
Kann man beides kostenlos als Demo runterladen und erstmal ausprobieren.
http://www.machsupport.com/
Ist glaube ich hier im Forum auch am meisten verbreitet.

Gruß

Alex

PS:Wenn dir das Look&Feel nicht gefällt kannst du sogar deine eigene Oberfläche dafür basteln. Anleitung dafür gibts auch direkt bei Artsoft. Herz was willst du mehr...
 
Hallo Andreas,
Zu Zeiten als ich noch nur mit WINPCNC ECO gearbeitet habe, kannte ich das Problem der Amnesy eigentlcih nur direkt beim ändern der Parameter. Waren die mal sicher gespeichert, hats eigentlch funktioniert. Gefährlcih fand ich nur immer das, das man beim "normalen" laden des G-Code gewisse zuvor mitgespeicherten Parameter geladen hat. Weclche das genua snd, weis ich farnicht, aber es waren Dinge wie Nujllpunkt usw. Könnnte Dein Problem hiermit etwas zu tun haben?

Was Alternativen anbelangt, ist es nciht ganz so einfach. ICh nutze regelmässig die 3 wohl meistbenutzten Programme in diesem Sektor. MACH 3, CNC-Graf und WINPCNC ECO. Ich kann Dir versichern das keines der Proggies Fehlerfrei ist. Werden es wohl auch nie werden. Zur Zeit arbeite ich am liebsten mit MACH 3 in Verbindung mit dem Smoothstepper. Dies ist FÜR MICH der zur Zeit beste Kompromiss. NC-Start, welches deer Vorläufer von CNC-Graf ist, ist aber wirklcih keine Alternative.. das Programm ist rein von der Ausgabe dr Schnittstelle einfach nciht mehr Zeitgemäss für die heutigen Fräsen.

Ruf mich doch einfach die Tage mal an und wir sehen was wir da für Dich machen könne . Bei deinem CAM hats ja auch geklappt. IN diesem Zusammenhang, kann cih dir dann auch gleih ncoh einen schönen neune Postprozessor für Dein CAM geben.

Gruss
Roy
 
Hi Roy,

danke für die Antwort. Dachte mir das fast. Da alles bei mir aus dem Cut2D kommt habe ich auf den G-Code nur Einfluss über den Postprozessor. Ich nutze noch immer den den Du mir mal gegeben hatest. Leider übergibt der keine Geschwindigkeiten fürs Werkzeug bzw. Winpcnc kann damit nix anfangen.
Vectric hat mir dann mal nen PP für die Haase geliefert und der hat mich zwei Fräser gekostet weil die Fräse danach immer tangential mit voller "Z" Zustellung ins Material gerauscht ist....... Hab ich dann im winpcnc "Geschwindigkeiten in Datei ignorieren" angeklickt war der Effekt weg, die Werkzeuggeschwindigkeit logischerweise dann auch........:rolleyes:

Der Support von vectric hatte dann irgendwann lapidar geschrieben das sie mir nicht helfen können.......

Bei einer der Aktionen muß dann im winpcnc irgendwas passiert sein, denn wenn ich jetzt in dem Menu für manuelles fahren gehe und dort die Spindel per Häkchen aktiviere dann fährt die Fräse sobald ich z.B. nur "Z" zustellen will, diagonal mit "Z" und "Y"!!! deaktiviere ich die Spindel und klicke dann die "Z" Achse läuft nur die "Z" Achse....... so wie es sein sollte....

Irgendwas ist da total daneben.....

Ich bin aber mit meinem Latein am Ende.....

Ich hab leider den Nimbus das ich in Software immer die Bugs als erster entdecke. Kein Scherz, wenn ich bei uns in der Firma Software teste dann dauert es maximal zwei Minuten bis ich da was drin finde...... Scheint irgendwie ein schlechtes Karma zu sein :D
 
hallo,
wer eine reine CNC sucht und vor Pinguinen keine Angst hat sollte sich EMC2 ansehen.
Was gibt es sonst noch das grafisch orientiert arbeitet??
Den funktionsumfang von winpcnc kenn nicht, was meinst Du mit grafisch orientiert.... EMC2 ist "nur" eine CNC und nur auf Linux lauffähig. Man muss also mit fertigem G-Code ankommen. z.B. mit BoCNC erzeugt.

Grüße, Gerd
 
grafisch orientiert meine ich mit das ich die geladene Datei sehe und auch sehe wo der Fräser gerade ist und nicht nur reinen G-Code. Mit G-Code kann ich nix anfangen.
 
Hallo Andreas,
Ich weis jetzt nicht mehr welchen PP du genau hast, aber meines Wissens hatte ich nie einen ohne Geschwindigkeiten.
An deiner Stelle würde ich folgendes machen:

1. Bei Lewetz die aktuellste Version Anfordern
2. Alle Parameterbildschirme per Bildschirmausdruck "sichern"
3. WINPCNC deinstallieren
4. WINPCNC neu installieren
5. Alles wieder richtig einstellen

Da jetzt ein definierter Zustand vorhanden sein dürfte, kann man darauf aufbauen. Wenn jetzt der "Diagonalbug" oder sonstiges weiterhin auftritt, kann man sicher sein es ist eine Falschparametrierung, bei welcher Dir Lewetz oder ich sicher sehr schnell helfen können.

So.. jetzt muss ich los, eine maschien inbetriebnehmen.... Werde mir heut abend deine Mailadresse rqaussuchen und Dir den aktuellsten PP zukommen lassen. Der Funktioniert dann für WINPCNC, MACH3 und CNC-Graf...

Gruss
Roy
 
Hallo Andreas,
ich würde es auch so machen wie es Joy vorgeschlagen hat.
Noch ein Tip. Speichere die Dateien WCNCCON.SYS und WINPCNC.WPI in dem WINPCNC Ordner separat ab. Wenn Du deinen Computer mal wieder strubbelig hast, kannst Du die Dateien einfach wieder in das Verzeichnis kopieren und deine vorher eingestellten Parameter sind wieder vorhanden.
 
Danke für die Tips,

heute wird aber erstmal Jet geflogen.

Gestern wieder derselbe Schei..... Habe vorgestern noch ganz normal gefräst, alles OK, gestern dann eingeschaltet neue Datei geladen und die Maschine fährt tangential mit voller Wucht komplett bis zur Opferplatte ins Material. So schnell konnte ich nicht mal den Notaus reinschlagen.......

Einstellungen gecheckt und die Häkchen bei "Geschwindigkeiten in Datei ignorieren" waren wieder weg!!! 100% waren die zuvor gesetzt!!!!
Was die mit dem tangential verfahren zu tun haben ist sowieso die Frage, aber zumindest wenn diese angetickt sind läuft die Fräse normal.

Zudem ignoriert die Kiste beharrlich den "Z" Nullpunkt obwohl ich den schon mehrfach abgespeichert habe.....

Ich hasse sowas.....
 
Hallo Andreas, was willst Du für Win Pc Economy haben? Vorausgesetzt, das Du das Programm noch verkaufen willst. Bin noch nicht lange in der "Hobbyfräsliga" und hab bisher nur mit Demos gewerkelt. Schreib mir mal Deine Vorstellung an ansy-64@gmx.de

Gruß ebenfalls Andreas
 
Hallo Andreas,

wenn Du das Pech wirklich so anziehst, würde ich mir wirklich
überlegen die Fräse überhaupt in Betrieb zu nehmen. Da kann doch
das Schlimmste passieren;) Wäre da nicht eine Laubsäge besser?

Grüsse, Raimund
 
Ansicht hell / dunkel umschalten
Oben Unten