AMW 102v3 von cnc-plus mit emc

Hallo zusammen,
ich bin am versuchen die Steuerung AMW 102v3 in emc zu konfigurieren. Aber irgendwie will das nicht so recht klappen. Benutzt einer diese Steuerung mit emc?

grüße
 
zusarvusar schrieb:
ich bin am versuchen die Steuerung AMW 102v3 in emc zu konfigurieren
AMW 102v3 kenn ich nicht, aber EMC2 kenn ich ein bisschen.
Wenn Du mir sagst was genau nicht so recht klappt, bzw wos Deiner Meinung nach klemmt kann ich vielleicht helfen.
Hab mal kurz das datenblatt von AMW 102v3 angesehen. Sollte eigentlich problemlos gehen.

Grüße, Gerd
 
Hallo,
ich bin mir nicht sicher mit den Werten die ich eintragen soll. Hab jetzt die anweisung bekommen
- Step Time - 10.000
- Step Space - 10.000
- Direction Hold - 5.000
- Direction Setup - 5.000
muss ich heute Abend mal so versuchen. Bisher sind die Motoren nie richtig gelaufen.
Nur über die Standart Stepper_mm konfiguration. Aber da passt ja dann von der auflösung nichts.
 

Anhänge

  • ScreenHunter_01 Jul. 09 09.32.gif
    ScreenHunter_01 Jul. 09 09.32.gif
    59,8 KB · Aufrufe: 56
sind schon gelaufen. aber irgendwie auch zu schnell. musste die geschwindigkeit auf 5% stellen. das kanns ja auch nicht sein.
wie/wo stelle ich die korekte auflössung ein?
 
zusarvusar schrieb:
wie/wo stelle ich die korekte auflössung ein?
Es gibt ein konfigurationstool (stepconf wizard) für standard anwendungen. Das ist ziemlich selbsterklärend. Ich benütze es aber nicht, weil meine styroschneide schon sehr speziell ist.
Ich mach aber alles direkt in den konfig files. Die Auflösung steht im ini file, z.B bei mir für die x-Achse:
Code:
[AXIS_0]
...
SCALE = 7.8
d.h. es werden 7.8 schritte pro einheit (bei mir mm) benötigt. Ich nehme an, bei Dir ist die Einheit ebenfalls mm, dann musst Du nur noch wissen wieviel Schritte der Motor für einen mm Verfahrweg machen muss.

Um das Richtungssignal einer Achse zu invertieren musst Du im hal file sowas suchen:
Code:
net xdir => parport.0.pin-03-out
Das heisst, dass das Richtungssignal der x-Achse auf pin 3 des pports ausgegeben wird. Zum invertieren fügst Du folgende Zeile ein
Code:
setp parport.0.pin-03-out-invert 1
Damit wird der pin3 invertiert.

Grüße, Gerd
 
Hallo,
habe gestern mal versucht die Richtung zu vertauschen. Hat super geklappt. Danke dafür :)
Die auflösung hab ich auch mal eingestellt und die Fahrwege vorgegeben. Aber ganz nach meinen Wünschen hat es noch nicht funktioniert. Ich tüftle da noch ein bisschen rum. Hab aber gerade leider nur sehr wenig Zeit :(

Vielen Dank für die bisherige, wertvolle Hilfe
 
zusarvusar schrieb:
Vielen Dank für die bisherige, wertvolle Hilfe
bitteschön.

noch eine Anmerkung:
Ich entnehme Deinen Antworten, Du verwendest nicht den stepconf wizard.
In Deinem Fall könnte das aber durchaus funktionieren, das ist dann etwas komfortabler.
Dazu noch folgender Hinweis:
Es gibt eine neue bugfix version von EMC2 (2.3.2). Da sind sind auch ein paar Fehler im stepconf wizard beseitigt.
http://sourceforge.net/project/shownotes.php?group_id=6744&release_id=695865

Grüße, Gerd
 
mh, dann werde ich den Bugfix mal einspielen und nochmal versuchen. Hoffentlich hab ich am Wochenende zeit dafür.
Ich berichte weiter ;)
 
Hab die Maschiene jetzt am laufen (konnte bei der Arbeit einfach nicht mehr still sitzen :) )
Einzigstes Problem an dem Configurations wizzard war das er mir bei den Motoreinstellungen irgend welche komischen werte eingetragen hatte. Diese hab ich raus und schon läufts. Muss mal noch genau schauen wie die werte hießen. Aber dann müsste ich jetzt wieder in den Keller.
Aber ich werde berichten
 
Hallo zusammen.
Die Fräse läuft soweit. einzigstes Problem ist der Werkzeugradius. Wie kann ich den mit einstellen. Bisher wird immer vom mittelpunkt des fräsers ausgegangen. somit sind natürlich alle teile um den werkzeugdurchmesser zu klein.

Hat da jemand einen tip?
 
Die Programmbearbeitung zur Fräserradiuskorrektur kannst Du z.B. mit BoCNC machen, ein sehr gutes und dazu kostenloses Programm, zu finden unter www.bocnc.de
 
Danke,

hab mir das Programm mal runter geladen. Scheint ganz gut zu sein. Leider hab ich es noch nicht in den Keller an die Fräse geschaft :(
Aber ich denke mit dem wird es gut gehen.

Dann kann ich jetzt bald mal die erste Teile für die Fokker DVII fräsen :)
 
Bekomme G-Code aus BoCNC nicht zum laufen

Bekomme G-Code aus BoCNC nicht zum laufen

Bin schon die ganze Woche am tüffteln. Bekomme aber den Code aus BoCNC nicht unter EMC2 zum laufen. Viele Ausdrücke können nicht gelesen werden.
Habe dann auch mal versucht über dfx2gcode die Radiuskorrektur zu machen. Hat leider auch nicht funktioniert.
Hat jemand für mich eine Lösung?
 
Ansicht hell / dunkel umschalten
Oben Unten