• Liebe RC-Network Benutzer: Bitte beachtet, dass alle Passwörter zurückgesetzt wurden. Mehr dazu in den News...

    Momentan sind leider keine Neuregistrierungen möglich, um eine schnelle Unterstützung der bereits registrierten Benutzer zu ermöglichen.

DIY Multi-Wii Quadrocopter

@Andy: So kannst du es machen! Da entnimmst du ja aus allen Zellen was.

@x4FF3: Mach es so wie bei Andy auf dem Bild, dann ist es richtig. (ACHTUNG! Nur bei 3S!!!)
Solltest du z.b. einen 6S Akku fliegen, müsstest du entweder das debalancen hinnehmen, oder mit einem Spannungsteiler o.ä. arbeiten.

Gruß Daniel
 
Regelung

Regelung

Guten Morgen zusammen,

ich habe bei mir irgendwie das Gefühl, das die Regelung nicht stark genug gegensteuert.

Bzw. ich habe das gefühl, das wenn ich über einen gewissen Punkt hinaus neige ( ca. 20 - 30 Grad) die Regelung nicht mehr gegen steuert.

Woran kann das liegen? Hat jemand die gleichen Erfahrungen damit gemacht, wie ich?

Gruß
Jens
 
kleiner Nachtrag. Ich habe gerade auch festgestellt, das die Motoren die abgesenkt werden zwar schneller drehen, jedoch die gegenüber liegenden anschließend nicht merklich langsamer werden.

vielleicht gehört das auch noch zur Fehlerquelle....
 

Fabse

User
Die Kamerahalterung lässt sich aber nur schwenken?! So wie ich das sehe kann die nicht gedreht werden.

...kaum Online gestellt sind alle schon weg :cry:
Wollt mir eben auch noch einen ordern :cry:
 

Fox64

User
Motion plus clone

Motion plus clone

Hallo an alle,

ich hab jetzt nochmal sämtliche foren durchgestöbert und hab noch keinen identischen oder wenigstens sehr ähnlichen Aufbau finden können. Weiß jemand von Euch, welcher Anschluss welcher ist. Würde mir sehr weiterhelfen. Danke schonmal im Voraus!

Grüße Asmus
 

Fabse

User
Hallo an alle,

ich hab jetzt nochmal sämtliche foren durchgestöbert und hab noch keinen identischen oder wenigstens sehr ähnlichen Aufbau finden können. Weiß jemand von Euch, welcher Anschluss welcher ist. Würde mir sehr weiterhelfen. Danke schonmal im Voraus!

Grüße Asmus
Hast du hier auch schon geschaut:
http://www.rcgroups.com/forums/showthread.php?t=1332876
fast ganz unten.

PS: Bist glaub nicht der einzigste der einen Clone verbaut hat.
 

Michael Brakhage

Vereinsmitglied
Hallo Jens

hast Du schon Version 1.6 auf Deinem Arduino? Wenn nicht, dann bitte schnell machen :)
Weiterhin wuchte Deine Props !!! Für das wuchten der Motore gibt es ein englischsprachiges Video. Im Prinzip einen kleinen Kabelbinder aussen auf den Motor machen und solange verschieben bis der Motor nicht mehr vibriert.
Ich habe dies so getan und mein Copter hebt einwandfrei und senkrecht nach oben ab ohne jegliche Tendenz zu irgendeiner Seite hin abzukippen! Ich bin völlig begeistert. Als Props verwende ich nun wieder die Gaui-Props 8". Die gefallen mir besser als die GWS 3Blatt die ich vorher drauf hatte.
Die Version 1.6 ist meiner Meinung nach viel stabiler als die 1.5er.

Viel erfolg.
 
Hi Michael,

danke für die Tipps. Habe die 1.6er drauf.
Habe uch die 8er GAUI. Auswuchten kan nich ja mal machen (Probs)...
Aber Motor auswuchten???!! Davon habe ich noch nie was gehört. Hast Du vielleicht noch den Link zu dem Forum.

Meinst Du wirklich, daß mein Problem nur an den nicht ausgewuchteten Komponenten liegt.
Der Copter neigt sich so stark, daß ich auch erst dachte, ich hatte Motoren vertauscht.
Kann es vielleicht sein, daß die Motoren nicht synchron laufen? also 50% Gas beim linken bedeuten 75% Gas beim rechten oder so....

Jens
 

Michael Brakhage

Vereinsmitglied
BMA020

BMA020

Hallo

ich habe nun seit heute nachmittag den BMA020 Beschleunigungssensor verbaut. Dieser ist auf einer fertig aufgebauten Platine incl. Pegelwandler und Spannungsregulator bei ELV Elektronik für 5,95€ erhältlich und kann den Nunchuk vollkommen ersetzen.
Dies kann der BMA020 sogar sehr gut!

Hier mal ein Bild mit der Riserplatine wo der BMA020 leicht gedämpft aufgeklebt ist. Er wird parallel zur WM+ angeschlossen

P1110246 (Small).JPG

Es sind zwar Pullup Widerstände im BMA020 verbaut aber ich habe zur Sicherheit im Sketch der Version 1.6 die Pullups des Arduino aktiviert. So kann ich den Sensor abziehen und die WM+ wird trotzdem erkannt.

Der allergrößte Vorteil des BMA020 ist der, das dieser eine eigene Adresse auf dem I²C Bus hat und nicht eine gemeinsame mit der WM+. Daher kann der Sensor schneller ausgelesen werden. Meine Cycle Zeiten liegen ohne Sensor mit der originalen WM+ bei 3100 und mit dem BMA020 bei 3850-3900. Mit dem Nunchuk waren diese bei >6000!!!
Zum Fliegen kann ich nur soviel sagen das der Sensor sehr gut funktioniert. Ich hatte nur einen kleinen knick in der Pupille und hatte nicht gesehen, das die Platine um 0,8mm schief verbaut war. In Flugrichtung war der Sensor rechts 0,8mm höher. Das hatte zur Folge, das der Copter dachte er würde nach links stehen und hat nach rechtskorrigiert, bis der Sensor grade stand. Wenn ich den Stable Mode aktiviert habe driftete der Copter mit ca. 2 Grad nach rechts.

Auf dem Bild ist der Winkelfehler schon korrigiert. Morgen gehts weiter mit den Flugtests.
 
Oh Mann,

kein Feler ist zu dumm, als das man jemand ihn macht.
Ich glaube, ich habe zumindestens einen Fehler wenigier:

Da ich noch nie Schauwaffeln mit Chinaglocken und Probsavern geflogen bin, habe ich doch tatsächlich ALLE probsaver falsch herum montiert!!! Die Probs hingen einfach "undefiniert" auf dem Saver rum, wenn man ihn jedoch dreht, hat man einen Prima Anschlag, in den man die Probs "klipsen" kann.... mal sehen, ob das was bringt.

Jens
 

Michael Brakhage

Vereinsmitglied
Meinst Du wirklich, daß mein Problem nur an den nicht ausgewuchteten Komponenten liegt.
Der Copter neigt sich so stark, daß ich auch erst dachte, ich hatte Motoren vertauscht.
Kann es vielleicht sein, daß die Motoren nicht synchron laufen? also 50% Gas beim linken bedeuten 75% Gas beim rechten oder so....
Montier mal deine Props ab, schalte Deinen Sender an, stecke Deinen Akku an und schliesse den Copter mit FTDI an den Rechner an. Nun startest Du die GUI und schaltest den Copter scharf. Ohne Props ist das ja gefahrlos möglich.
Hier kannst Du nun eindeutig sehen welcher Motor hochdreht, wenn Du deinen Steuerknüppel bewegst. Wenn dies sinngemäß richtig ist, hast Du schonmal keinen Motor falsch angeschlossen. Also wenn knüppel nach rechts dann muss der linke Motor hochdrehen in der GUI. Sofern Du eine Quad+ Konfig hast. Bei Quadx die beiden linken Motore halt.

Nun kannst Du in der Gui testen ob der Sensor richtig herum arbeitet. Hierzu bewegst Du einfach bei halbgas den Copter und schaust nach welche Reaktion die GUI dir anzeigt. Wenn dies auch sinngemäß richtig ist solltest Du prüfen ob deine Motore an den richtigen Ecken verbaut sind. Dies kannst Du einfach hören wenn Du den Knüppel bewegst und dein Ohr an den entsprechenden Motor hälst.

Wenn dies alles richtig ist, dann wirds an ungewuchteten Props oder gar Motoren liegen.


Hier mal das Video zum Auswuchten der Motore


Ich hab das mal gemacht und es lohnt sich wirklich!!!
 
So, die Propsaver sind nun ricthtig rum, läuft schon viel besser...

Dennoch will er nicht fliegen.
Was mich wundert ist, daß der Wert für REAR ca 187 Einheiten höher ist als bei den anderen Motoren. Habe dazu den Copter an der langen Hand einigermaßen in der Horizontalen gehalten. Das würde auch erklären, warum er einen Vorwärtslooping machen würde, wenn ich richtig Gas geben würde. Was mache ich falsch???

Wii.JPG

Jens
 

Michael Brakhage

Vereinsmitglied
Hallo Jens

ich würde erstmal sehen das Deine Cycle Zeiten wieder in einen normalen Bereich kommen. Mach den Nunchuk ab!! Dann sollten diese bei einer originalen WM+ und 100Khz I²C Takt bei 3100 liegen.

Wenn Du den Copter festhälst oder er auf dem Boden steht ist die Regelung nicht wirklich aktiv, bzw. der Copter verhält sich nicht so als wenn er wirklich frei schwebt!

Wenn Du die Wirkrichtungen alle kontrolliert hast dann such Dir ne weiche Wiese und gib mal beherzt Gas sodas der Copter abhebt und in einer Höhe von min. 50cm schwebt. Dann bist Du einigermassen aus dem Bodeneffekt raus.

In freier Luft kann die Software vernünftig den Copter ausregeln. Das geht leider nicht wenn man ihn festhält!

Nochwas: Dein RC-Rate wert ist zu hoch! Das ist identisch zu Dualrate! mach den mal auf 0,7 und den Expo auf 0,5. Das ist dann besser für den Anfang geeignet!

Dein Pitchwert ist über 1500! also denkt die Software das Du nach vorne kippen willst! Deswegen wahrscheinlich auch die etwas höhere Drehzahl des hinteren Motors. Bring die in Ruhestellung mal alle auf 1500! per Trimmung!
 

StephanB

Vereinsmitglied
(...) Wenn ich den Stable Mode aktiviert habe driftete der Copter mit ca. 2 Grad nach rechts.
Michael,
verstehe ich das richtig, daß man (während des Fluges?) von normal auf "stable mode" umschalten kann?
Ich bin sehr gespannt auf deine Erfahrungen im stable mode mit dem BMA020. Meine KK-stabilisierten wandern halt doch ein wenig. Und der Arduino-WiiM+ Weg war für mich als weitgehend unvorbelastetem ElektronikDAU bisher aufgrund der vielen Problemschilderungen zum Nunchuk ein NoGo.
Grüße
Stephan
 
Oben Unten