ESTLCAM Steuerung von Arduinoclub Zusammenbau.

Hier nun mal einiger Bilder vom Zusammenbau der Arduinoclub Steuerung.
Noch mal Danke an Arduinoclub läuft alles TOP.

Mein Zusammenbau ist zwar nicht schön aber zweckmäßig.

Fragen zu den verwendeten Teilen werde ich gerne beantworten.

Pascal

k-IMG_20170708_143241.jpg
k-IMG_20170708_152450.jpg
k-IMG_20170709_115912.jpg k-IMG_20170709_115922.jpg
k-IMG_20170710_191840.jpg
k-IMG_20170710_191857.jpg
k-IMG_20170710_191800.jpg
k-IMG_20170710_191827.jpg
k-IMG_20170710_201323.jpg
 

deavik

User
Hallo,

Schöne Aufbau!

Habe letzte Woche auch eine Steuerungskarte gekauft (arduinoclub.de).

Bis jetzt habe ich LinuxCNC genutzt. CNC-Fräse ist Ende 2012 gekauft CNC6040

Letzte Zeit habe ich probiert mit Arduino Karte über LPT Anschluss zu steuern – einwandfrei.
Jetzt will ich voll auf ESTLCAM setzen. Es gibt natürlich dann für mich kleine Nachteile (G-code ist bei EstlCam einfacher, kann ich nicht mehr einiges machen), aber kann ich auch mit dem leben.

Kann es sein, das meine jetzige Schrittmotor - Treiber (T65-DKEN) nicht (richtig) direkt mit Arduinokarte funktionieren?

Habe nämlich versucht schnell zu verdrahten, Motoren werden aber nicht angesprochen.

Da ich so wie so andere Schrittmotortreiber gekauft habe (Leadshine-Clon M542), hoffe kriege zum Laufen.

Eine Frage – wie hast du Not-Aus geschaltet?
 
Arduinoclub Steuerung

Arduinoclub Steuerung

Hallo
Bei mir Trennt der NOTAUS einfach die 230 Volt zum Netzteil! Ein Richtiger Brutaler NOTAUS also.

Oder meinst du den Fehlereingang? den benutze ich nur als Stop.

Die Endstufen hättest du benutzen können, siehe in der Arduinoclub Anleitung unter Punk Abbildung 4.2.4
Variante 2 : Treiber benötigen einen gesonderten 5V Stromanschluss.
Die gleichen waren auch in meiner China LPT Steuerung.

Grüße
Pascal
 

deavik

User
Not-Aus will ich auch so machen.
Frage wegen Fehlereingang - für was ist es gut?
Wenn dies ausgelöst wird, kann man dann Maschine nur abnullen und weiter laufen, oder?

Meine Alte Steuerung Treiber haben keine extra 5 V Anschluss.
Siehe foto:

IMG_20170915_055107.jpg

Aber egal, neue sind gekauft und verbaut.
Muss nur die Front und Hinten Platte fräsen und Hochvoltage verkabeln...
Ich will im Extremfall umschalten können auf die alte LinuxCNC. :)

IMG_20170914_211646.jpg
 
Arduinoclub Steuerung

Arduinoclub Steuerung

Hallo.

Mit dem Fehlereingang kann man z.B. eine Türe an der Verkleidung überwachen. wenn du die Tür öffnest bleibt die Maschine stehen.
Türe zu sollte es weiter laufen, habe ich habe nicht.

Mit dem Poti vorne ändere ich die Drehzahl meiner Kress ( Kress 530 hat kein Drehzahlregler ).

http://www.ebay.de/itm/PWM-Drehzahl...195206?hash=item5b34489246:g:XVcAAOSw~oFXKE-D

Ich hoffe ich konnte dir Helfen.

Wenn du so weit alles fertig hast sage bescheid, kannst ein Connfig-File für ESTLCAM von mir haben den hast du schon die meisten Einstellungen.

Pascal
 

deavik

User
Hallo,

habe heute auf die schnelle hintere Platte gefräst.
So wird es aussehen:
Muss ich am Sonntag Verkabelung fertig machen.

IMG_20170916_204111.jpg
IMG_20170916_204115.jpg

Eine Frage:
reicht es Netzfilter für 230V mit 2 A? Oder soll ich einfach bessere kaufen (mit wieviel A?)? Habe einfach nur dies jetzt zur Hand.

Wenn ich so rechne, Fräse selber zieht max 3x3 A Motoren bei 24 V (9A) plus Karte dazu (also max 10 A)
also mache ich beim Rechnen max 15 A mit 24V gleich 360 Watt
360 Watt bei 230 V ist 1,565 A.
Also, muss 2A reichen oder liege ich da falsch? :)
 

deavik

User
Motoren werden über 4 polige Buchsen angeschlossen. Genau gleiche wie bei meiner linuxcnc Steuerung. Das sind Öffnungen auf dem Bild zu sehen. Buchsen sind noch unterwegs zwischen China und de.
So kann ich beide Steuerungen nutzen. Einfach umstecken, fertig.
 
Steuerung Arduinoclub

Steuerung Arduinoclub

Motoren werden über 4 polige Buchsen angeschlossen. Genau gleiche wie bei meiner linuxcnc Steuerung. Das sind Öffnungen auf dem Bild zu sehen. Buchsen sind noch unterwegs zwischen China und de.
So kann ich beide Steuerungen nutzen. Einfach umstecken, fertig.
Ich bin Beeindruckt, das sieht doch schon mal alles Top aus.
Weiter so.

Pascal
 

deavik

User
Hallo,

ist eigentlich fast alles verkabelt.
Einmal habe ich nur kurz eingeschaltet... Ich glaube es wird laufen :)

Ich warte auf Ali-Sendung mit 4-Polige Buchsen um Motorenkabel anzuschließen.
Da ich mich erst letzte Moment entschieden habe für 2. Steuerung, erste will ich auch betriebsbereit für LinuxCNC behalten, das wegen habe ich die Buchsen erst vorletzte Woche bestellt. :(
Zeit (wo ich so wie so nicht viel habe) nutze ich um vorhandene Kabel-Verbindungen zu löten, muss noch kleine vordere Platte für Ein-Aus und Not-Aus fräsen und in Fusion konstruiere ich eine sehr lang erwünschte einfache Staubabsaugung, will ich auch diese Woche fräsen.
Vorletzte Stand (ist mittlerweile wieder geändert): :)

IMG_20170921_193447.jpg
2017-09-26 14_08_10-Autodesk Fusion 360.png
 

deavik

User
Hallo,

also, es ist so weit.
Alles angeschlossen, die Frontplatte noch fehlt (Not-Aus schalter wieder irgendwo unterwegs :))
Endschalter werde ich später anschliessen, wenn überhaupt.
Fast alles läuft ohne Probleme, fräsen probieren will ich erst morgen. Zuerst habe ich bisschen mit Vorschuben gespielt, um optimal die einzustellen.(1800, trägheit 85%)

Was nicht läuft - Spindelansteuerung.

Zuerst paar Bilder:
IMG_20170930_195253.jpg
IMG_20170930_195229.jpg

Beim Spindel - ich habe FU mit eingebauten Poti. Model HY01D523B
Parameter PD001 und PD002 setze ich auf 1 und Jumper, welche rechts steht, setze ich links.
Normal ist so interne eingebaute Poti ausgeschaltet und alles auf externe Steuerung umgeschaltet.
Muss ich hier PD070 auch umprogrammieren?
in Moment steht es auf 1 (0-5V) - 0-10V kommt erst mit Einstellung 0 - habe geändert, Spindel wird immer noch nicht angesteuert.
Habe in Aus-Zustand Spannung 0-10V und DCM/FOR Signal von der Arduino Karte überprüft - es muss eigentlich funktionieren, aber es geht einfach nicht.
Komisch, aber beim FU einschalten schaltet sich Motor sofort an und lässt sich nur Ausschalten über Stop-Taste, einschalten nicht mehr.
Welche Parameter muss ich hier noch überprüfen?
 
Hallo deavik,


ich kann dir leider zu deiner Frage selbst nicht helfen, aber ich habe selbst 1-2 Fragen zu den von dir verbauten Buchsen und Steckern für die Endschalter:

1. Was sind das für Stecker und Buchsen für die Endschalter (Nehme an es sind die selben wie für Sensor, 0-10 V, etc.) und woher hast du die denn ?
2. Warum sind die eigentlich 3-polig ?
Eventuell weil deine Endschalter-Kabel geschirmt sind ? Ich dachte man muss nur die Schrittmotor-Kabel mit Schirmung versehen.


Gruss
schmiro

PS: Ansonsten noch viel Erfolg bei der Klärung deiner eigenen Fragen und beim Fertigstellen deiner Fräse !
 
Hallo,

also, es ist so weit.
Alles angeschlossen, die Frontplatte noch fehlt (Not-Aus schalter wieder irgendwo unterwegs :))
Endschalter werde ich später anschliessen, wenn überhaupt.
Fast alles läuft ohne Probleme, fräsen probieren will ich erst morgen. Zuerst habe ich bisschen mit Vorschuben gespielt, um optimal die einzustellen.(1800, trägheit 85%)

Was nicht läuft - Spindelansteuerung.

Zuerst paar Bilder:
Anhang anzeigen 1846063
Anhang anzeigen 1846068

Beim Spindel - ich habe FU mit eingebauten Poti. Model HY01D523B
Parameter PD001 und PD002 setze ich auf 1 und Jumper, welche rechts steht, setze ich links.
Normal ist so interne eingebaute Poti ausgeschaltet und alles auf externe Steuerung umgeschaltet.
Muss ich hier PD070 auch umprogrammieren?
in Moment steht es auf 1 (0-5V) - 0-10V kommt erst mit Einstellung 0 - habe geändert, Spindel wird immer noch nicht angesteuert.
Habe in Aus-Zustand Spannung 0-10V und DCM/FOR Signal von der Arduino Karte überprüft - es muss eigentlich funktionieren, aber es geht einfach nicht.
Komisch, aber beim FU einschalten schaltet sich Motor sofort an und lässt sich nur Ausschalten über Stop-Taste, einschalten nicht mehr.
Welche Parameter muss ich hier noch überprüfen?
Hast du deine Fragen schon mal an Artduinoclub gesendet? die helfen immer weiter.
Ich hatte auch schon mal ein Problem die sind sehr Hilfsbereit.

Grüße
Pascal
 

deavik

User
Hallo deavik,


ich kann dir leider zu deiner Frage selbst nicht helfen, aber ich habe selbst 1-2 Fragen zu den von dir verbauten Buchsen und Steckern für die Endschalter:

1. Was sind das für Stecker und Buchsen für die Endschalter (Nehme an es sind die selben wie für Sensor, 0-10 V, etc.) und woher hast du die denn ?
2. Warum sind die eigentlich 3-polig ?
Eventuell weil deine Endschalter-Kabel geschirmt sind ? Ich dachte man muss nur die Schrittmotor-Kabel mit Schirmung versehen.


Gruss
schmiro

PS: Ansonsten noch viel Erfolg bei der Klärung deiner eigenen Fragen und beim Fertigstellen deiner Fräse !
Hallo schmiro,

Buchsen für Motoren sind 4-Polig - genau so wie bei meiner LinuxCNC Steuerung. -
Bestelllink:
https://www.aliexpress.com/item/10pcs-set-Aviation-Panel-Connector-Metal-Female-Socket-Male-Plug-GX16-4-Pin/32776129751.html
Jetzt kann ich einfach Kabel umstecken, dann läuft alles mit ESTLCAM. Hie rmuss man aufpassen, es gibt mit 16 mm Durchmesser und mit 19. Bei mir sind die mit 16mm.

Für alle andere Verbindungen (Sensor, Endschalter) habe ich 3-Polige genommen. - Das sind ganz normale XLR Steckverbindungen.
https://www.aliexpress.com/item/10pcs-3-Pin-XLR-Female-MIC-Audio-Microphone-Chassis-Mount-Coupler-Connector/32758583844.html

https://www.aliexpress.com/item/5PCS-Nickel-Plated-3-pin-XLR-Audio-Cable-Connector-MIC-male-Plug/32606912565.html

Für Sensor reicht eigentlich schon 2-Polig, aber am Ende habe ich kleine Fehler gemacht, ich sollte eigentlich für alle Verbindungen 4-Polige nehmen, alle Leitungen brauche ich nicht, aber z.B. bei Fehlereingang kann ich dann auch solche schöne beleuchtete Tasten benutzen, (2 andere Leitungen für 24V) aber egal.

https://www.aliexpress.com/item/ELEWIND-22mm-BLACK-aluminum-Ring-illuminated-Momentary-push-button-switch-PM221F-11E-G-2-8V-A/1346339630.html

Wie gesagt - für Sensor, Fehlereingang könnte man gleich 2 Polige XLR nehmen. Ich habe aber für alles gleiche 3-Polig bestellt.
Endschalterkabel sind bei mir so wie so geschirmt. Habe kein anderes Kabel zur Hand gehabt :)

deavik
 
Oben Unten