Estlcam Version 11

onki

User
Hallo nochmal,

wie gesagt es geht auf dem "manuellen" Weg, der aber entsprechend Disziplin erfordert und Gefahren birgt.
Dazu müssen beide Konfigurationen gemacht werden und danach abgespeichert werden. Dann kann man immer die gewünschte Konfiguration laden und übernehmen. Mag ein gangbarer Weg sein, wenn nur selten gefräst wird. Dann ist aber auch die Gefahr groß, dass man vergisst die Steuerung richtig einzustellen (Faktor Mensch halt).

Daher wäre ein Ansatz das so einzubauen, dass man mit der Startverknüpfung eine Konfiguration mit aufruft also beispielsweiose so "estlcam.exe /config:fraese_xyz.txt"

Damit wäre die Sache recht komfortabel erschlagen. Muss aber erst noch eingebaut werden.

Gruß und ein schönes Wochenende
Onki
 

k_wimmer

User
@Schrauber_men:
Kannst du mir auch den Grund dafür nennen?
Denn dann läuft alles immer über den gleichen Com-Port, und genau DAS gilt es in einem solchen Fall normalerweise zu vermeiden!

@onki:
Da ich unterschiedliche Adapter für die Fräsen nutze, könnte man das auch jeweils dem Adaptertyp zuweisen, und dann einfach nur in der Steuerung zwischen den Adaptern umschalten.
 
Kannst du mir auch den Grund dafür nennen?
Hallo
wenn du 1x Software an 2x Controller verwedest(benutzt) , dann soll man ständig USB -Port manuel auswählen
mit nur 1x USB braucht man nicht, nur umschalten
Wenn man doch 2x USB benutzen will ,dann sollte Arduino (gerade nicht benutzt) von Strom trennen ,dann wird automatish den andere erkannt, so kann man probieren, ob so geht, weiss ich nicht, aber denke, so kann es auch gehen, sonst nur mit 1x USB und Umschalter

Da ich unterschiedliche Adapter für die Fräsen nutze, könnte man das auch jeweils dem Adaptertyp zuweisen
Nein , das hat nicht mit adaptern zu tun, weil im Endeffekt beide Steuerungen laufen über USB !!! man soll dann USB-Port auswählen

Gruß
Waldemar
 
Eigentlich ist das Problemlos möglich, siehe hier: https://www.estlcam.de/allgemein_profile.php

Man wird aber für die 2. Anlage/Fräse oder Programmversion "z.B. Links / Rechtslauf" alle Einstellungen neu machen müssen.
Möglich das die eine oder andere Datei/Ordner vom Ursprungsordner V11 mit Kopiert werden kann, da es hier aber eh um
eine neue Einrichtung handelt, kann man auch alles neu einstellen.

1.
Die Verknüpfung von Estlcam Kopieren und In der Kopierten Verknüpfung von Estlcam z.B. folgendes eintragen:

2.
unter Ziel: "C:\Program Files (x86)\Estlcam11-11.216\Estlcam32.exe" Profile=Fräse2

3.
Die neue Verknüpfung Starten und der Ordner "V11_Fräse2" wird angelegt.
Programm wieder beenden!

4.
Anschließend die neue Verknüpfung noch mal bearbeiten und unter "Ausführen in:" hinter V11 folgendes anhängen " _Fräse2 "
so das es wie folgt aussieht: C:\ProgramData\Estlcam\V11_Fräse2
Die Verknüpfung kann entsprechend umbenannt werden ;)

Jetzt wird beim Aufrufen der "Fräse2" auch der Ordner V11_Fräse2 verwendet und hier werden die Einstellungen nun für diese abgelegt!
Der alte V11 Ordner ist immer noch für die Original Verknüpfung und somit lassen sich auch mehr als 2 Anlagen oder Programmeinstellungen realisieren :D
 
Nachtrag!
Ich bin mir nicht sicher ob es Wichtig oder nötig ist, aber falls man 2 Anlagen mit einem PC Steuern möchte,
sollte glaube ich auch die Verknüpfung: CNC Controller V11 entsprechend Kopiert, umbenannt und unter
"Ausführen in:" der Ordner wie oben " C:\ProgramData\Estlcam\V11_Fräse2 " angepasst werden.
Nicht das die Fräse Spinnt weil sie die Einstellungen von der 1. Fräse nimmt und sonst was macht :eek: ;)

EDIT: Gerade mal getestet, man muss auch das Ziel wie oben ändern!
Es kommt eine Fehlermeldung, das man diese an den Entwickler schicken soll, kann man ignorieren ;-)

Bei Ziel also folgendes in der Kopie vom Controller eingeben: "C:\.....\Estlcam11\Estlcam.exe" Controller Profile=Fräse2
Anschließend ruft Estlcam den Ordner V11_Fräse2 auf, in meinem Fall noch keine Einstellungen vorhanden,
daher kommt auch die Meldung das die Steuerung noch nicht Konfiguriert wurde.

Falls die Beschreibung Falsch ist, sollte sich der Programmierer dazu Äußern, Danke!

EDIT: Alle Angaben ohne gewähr und auf eigenes Risiko!
Ich bin dann mal wieder WEG 👋
 
Zuletzt bearbeitet:

k_wimmer

User
Danke Hardy,
hätte ich auch selber finden können :).
Ist aber genau das was ich gesucht habe. und funktioniert absolut tadellos !
 
Danke für die Rückmeldung!
Man findet halt manchmal den Wald vor lauter Bäume nicht :cool:
Da ich mich aber mit dem Thema schon vor einiger Zeit beschäftigt hatte (Links und Rechtslauf), war das Griffbereit ;)
 

onki

User
Hallo,

ist ja putzig, dass ich die gewünschte Funktionalität so beschrieben hab, wie sie schon umgesetzt ist.

Gruß und ein schönes WE

Onki
 
Hallo,

für mehrere Maschinen muss nur der "Ziel" Eintrag der Verknüpfung mit dem "Profile=" Zusatz ergänzt werden.

Es gibt allerdings Fallstricke:
  • Wenn man die USB Kabel raus zieht kann es passieren dass sich danach die "COM" Port Anschlüsse vertauschen und Profil A plötzlich Maschine B und umgekehrt anspricht oder das Betriebssystem sogar eine ganz neue COM Port Nummer vergibt. Bei so einer Konfiguration sollten die Kabel entsprechend immer drin bleiben.
  • Es ist problematisch mehrere Maschinen gleichzeitig vom selben PC aus zu steuern - manche Tasten wie z.B. die ESC Taste wirken (absichtlich) global und halten dann beide Maschinen an auch wenn man nur eine stoppen wollte. Andere Sachen wie z.B. Gamepads lassen sich wiederum gar nicht teilen und funktionieren nur für das zuerst geöffnete Fenster. Und bei schwachen PCs kann es dann auch mal zu Flaschenhälsen kommen so dass die Zuverlässigkeit der Steuerung insgesamt leidet.
(Ich komme leider nur noch selten dazu hier im Forum mitzulesen - seit Monaten bin ich restlos ausgelastet. Die Entwicklung geht aktuell nur sehr schleppend voran, so dass vor Sommer wohl nicht mehr viel passieren wird.)

Christian
 
Hallo,

für mehrere Maschinen muss nur der "Ziel" Eintrag der Verknüpfung mit dem "Profile=" Zusatz ergänzt werden.
OK, Danke für die Rückmeldung!
Allerdings ist mir aufgefallen das beim "Profile=????" zwar ein neuer Ordner angelegt aber die Einstellungen im V11 statt im V11_???? abgelegt werden?
Es wurden also Änderungen vorgenommen, die anschließend im alten Profil ebenfalls geändert wurden aber nicht im neuen V11_????.

Ändert man anschließend auch "Ausführen in", wurden die Einstellungen in dem neuen Ordner V11_???? abgelegt ohne den V11 zu beeinflussen und das macht Programmtechnisch auch Sinn außer es werden für die neuen Anlagen auch neue Dateien in dem Ordner V11 angelegt "was nicht der Fall ist".
Gleiches gilt für das Ausführen des Controllers, ändert man hier nicht's, werden die Einstellungen aus V11 genommen.
Ob's ein Bug ist oder nicht, kann ich nicht sagen, die Kommandozeilen Ebene ist ja für solche fälle ausreichend und gut, sofern sie Dokumentiert sind ;)

Egal, mit den Antworten ist die gewünschte Funktion ja offengelegt ?
und man kann 2 Anlagen "nicht gleichzeitig" mit Estlcam auf einem PC ansteuern ohne ab stöpseln des USB Anschlusses, was ja die Frage war.

Da braucht es glaube ich keine weitere Funktion, außer man könnte innerhalb vom Programm die Pfade auswählen und ändern oder das Programm getrennt von der Aktuellen Installation erneut Installieren.

Man kann es aber so lassen wie es ist ;)
 

k_wimmer

User
Doch, ich kann beide drin lassen, das ist kein Problem. Ich MUSS sie dann nur angesteckt lassen, da Windows sonst eine neue Initialisierung der Portzuordnung durchführt.

Und genau das ist bei mir kein Problem, da ich beide Fräsen dauerhaft installiert habe und der Laptop in einer Dockingstation sitzt.
 
In welche Endgültigen Estlcam Version kommt das wo man mit einem Taster über Makros zb den WLZ oder die Schrittmotore freifahren kann ?
 
@4noxx
Sorry, aber in dem Bild steht doch "Steuerung nicht Konfiguriert..." wie soll da ein Fräsprogramm laufen bzw. das Funktionieren?
Um die Fräse ansteuern zu können, muss erst der Adapter oder Arduino richtig gefüttert werden, ein Simulationsmodus gibt es da nicht ;)
Ich lasse mich aber gerne eines besseren belehren, könnte ja sein das ich in den 20 Versionen was verpasst habe :D
 
Also Fräse ist angeschlossen, Steuerung funktioniert und das Programm ist am Fräsen?
Sobald unten auf die Leiste geklickt wird, öffnet sich dann das Einstellungsfenster und bricht den Fräsvorgang ab.
Meinst Du das?

Bei nicht angeschlossener Fräse macht das ja sin, aber beim Fräsen natürlich nicht :confused:
Ich kann es an der Fräse nicht Testen da noch nicht aktualisiert, ein Grund mehr nicht immer auf die neueste Version zu Springen :D
Geh doch erst mal wieder auf Version 11.235 falls nicht gerade "Kreistaschen mit Schlichten.." benötigt wird, da ist das noch nicht!
 

k_wimmer

User
Ich habe da auch noch einen Bug gefunden.
Ist mir direkt an der Fräse noch nicht aufgefallen, da ich da nur einen Monitor dran habe.
An meinem CAD-Arbeitsplatz habe ich aber mehrere Monitore dran, und da fällt es dann auf.

Hat man die Einstellfenster innerhalb des Hauptfensters funzt alles normal.
Schiebt man aber das Einstellfenster auf den 2ten oder 3ten Monitor, dann gehen dort die PullDown Menüs nicht mehr ! (V11.235)

Die 11.236 habe ich noch nicht getestet.
 

RayX

User
Vorab ich habe die Fräse seit Weihnachten und bin neuling.... also wenig Ahnung.
Heute habe ich meine Tastplatte bekommen und angeschlossen.
Allerdings denke ich das da auch ein Fehler drinnen ist, das ganze funktioniert soweit gut, aber meine Tastplatte ist 100X100mm und das habe ich im Setup Menü auch so eingestellt um die Winkel Genauigkeit zu erhöhen.
wenn ich jetzt starte tastet Z ganz normal an dann fährt sie auf den ersten tastpunkt und tastet auch ganz normal an aber beim letzte Tastpunkt fährt si nur ca 15-20mm und tastet dann auch ganz normal an.
Eigentlich müsste sie aber 95mm fahren und dann antasten und nicht nur 15-20.

Der Weg der tatsächlich gefahren wird ändert sich nicht egal was man im Setup einstellt, ob man 5mm oder 300mm einstellt ist egal die Maschine fährt immer den gleichen weg.

Ist das ein Fehler oder denke ich einfach nur falsch oder bin vielleicht einfach zu doof das richtig einzustellen ?
Meine Version ist 11.235

Gruß
RayX
 
Moin RayX
Bei mir fährt sie auch nur 25 mm wenn ich auf Verdrehung klicke dann 1 mal mehr also einen zussätulichen Punkt
wenn sie bei dir auf 95mm fahren würde könnte sie die Zweitfunktion gar nicht machen da sie ins Leere laufen würde
Gruß Jan Henning
 
Oben Unten