Geeetech Prusa i3 pro B druckt nicht von SD Card

Kyrill

User
Der oben angeführte Drucker arbeitet wie er soll am USB Kabel.

img20160516_105526.jpg

Will ich ihn jedoch mit einer SD Karte alleine arbeiten lassen, versagt er. Das Einstecken der Karte wird im Display angezeigt, aber im nächsten Menupunkt, nach dem Druck auf den Wahlknopf erscheint in der untersten Zeile: No SD Card.

Gibt es eine versteckte Softwarefunktion wo man den Cardreader aktivieren kann?
Die SD Karte wurde über Repetier Host beschrieben wie im User-Manual des Druckers angegeben.

Leider weiß ich nicht welche Firmware-Version auf dem GT 2560 Treiberboard aufgespielt ist. Deshalb möchte ich die Firmware nur neu aufspielen wenn unbedingt erforderlich. Der Drucker druckt jetzt über Kabel und ich traue mich nicht was zu ändern, weil ich jetzt installierte Firmware zunächst nicht sichern kann, um eventuell zurückzubauen...
 

cord

User
Hast du die Karte schon mal neu formatiert? Dafür gibts auch Tools, z.B. SD-Formatter. Oder mal eine andere Karte probieren. Sind die Kabel zum SD Adapter vielleicht zu lang?
Nur mal so meine ersten Ideen...

Gruß
Cord
 

Michael Brakhage

Vereinsmitglied
hi

hat der zufällig marlin als firmware?

dort muss die sd karte im sketch aktiviert werden.
wenn die sich selbst eine firmware gebastelt haben, dann kann man das schnell mal vergessen.... mir auch passiert :)

problem wird wohl sein, die firmware (sketch) von denen zu bekommen.... aber fragen kostet nix.

mach doch mal nen bild vom display (betriebsbereit) dann können wir dir sicher sagen, welche firmware.
 

Michael Brakhage

Vereinsmitglied
scheint marlin zu sein.
kannst du die nicht mal anschreiben, ob sie dir die config-dateien schicken?

ist ja opensource von daher sollten sie es rausrücken.

alternative ist noch der umbau auf eine andere hardware wie z.b. ramps oder sowas. da die meisten i3 mit einem ramps laufen gibt es da genug anhaltspunkte.
 

Target

User
da ich auch einen Geeetech prusa i3 x pro mein eigen nenne verweise ich hier mal auf dem doch ganz gut gefülltes wiki ;)

http://www.geeetech.com/wiki/index.php/GT2560

ggf ist der Kartenleser am LCD (das zweite Flachband-Kabel!!!) falsch oder beschädigt, wenn es in der Firmware aktiv ist wovon ich ausgehe da das lcd ja den Füllstand anzeigen möchte. Wenn die Zeile für den Reader auskommentiert ist wird nach meiner Meinung nach das dort nicht mehr angezeigt.

Ich schaue sobald ich wieder zu Hause bin mal meine Config bzw Settings nach.

Gruß
Sascha
 

Kyrill

User
Hallo Sascha das wäre lieb von dir.
Ich habe gerade die Firmware auf anraten von Geeetech neu aufgespielt. aber geändert hat sich nichts. Die SD wird nicht erkannt. Nur das Einstecken der Karte wird registriert. In der config.h ist im unteren Viertel ein auskommentierter Bereich wo ich noch einmal etwas zu der SD Card gefunden habe. Wenn ich das aktiviere tut sich aber auch nichts...

Wäre schön wenn du helfen könntest.
 

Target

User
Also,

ich hab bei mir jetzt grad mal das Verhalten zur SD Karte getestet

[video]https://drive.google.com/open?id=0B5QOgMo4taiUTE1EWHJGV2lXMEU[/video]

und das ist die default marlin firmware ohne Änderung, würde jetzt nach deiner Schilderung davon ausgehen das entweder der Kartenleser n Hau hat oder das Simplere das Kabel und das kannste leicht testen: Tausch die beiden Kabel aus also sowohl am Display als auch auf dem GT2560 Board. Entweder geht nach dem Tausch und einschalten das Display nicht korrekt oder es geht doch und der Kartenleser ist wirklich defekt.


Gruß
Sascha
 

Kyrill

User
Danke fürs ausprobieren. Ich habe die Kabel getauscht, ohne sichtbare Veränderung. Ich habe sogar deine Firmware vom Pro X aufgespielt und den SD Cardreader ausprobiert. Dito. Rein und raus der Karte wird angezeigt aber keinerlei Datei wird gelesen oder erkannt, respektive das SD Card Menu ist nicht erreichbar weil No SD card angezeigt wird in Untermenüebene 1.
Hab Geeetech jetzt gebeten das Display mit dem Reader neu zuzusenden. Mal sehen was passiert...

Falls noch jemand der Leser eine weiterführende Idee hat raus damit...
 

Kyrill

User
Problem noch da..

Problem noch da..

Nachdem der freundliche Chinese ohne Probleme den Cardreader mit Display neu zugesandt hat, mußte ich feststellen, dass der Tausch das Problem nicht beseitigt hat. Der Kartenwechsel wird erkannt, nicht jedoch die Karte ausgelesen. Gespeicherte Dateien werden nicht angezeigt und entsprechende Menupunkte für den Druck von Karte werden nicht angezeigt.
Kann es vielleicht doch an dem Zusammenspiel Hardware<>Software liegen? Bin für alle Tipps offen...
 
Ansicht hell / dunkel umschalten
Oben Unten