OpenXSensor für Telemetriesensoren

... Ich nehme an es liegt am Sensos? Verbaut wurden blaue "GY-BMP280"

Wenn jemand eine Idee hatte wo der Fehler liegen könnte wäre ich sehr Dankbar, 3 Varios die die Höhe nicht messen sind schließlich nicht sehr hilfreich. :rolleyes:
Ist das denn noch aktuell?

Blaue Platinchen habe ich bisher nur für BME280 gesehen, nicht BMP280.
Für den BME280 funktioniert OXS aktuell noch nicht (nur BMP085, 180 und 280).

Gruß
 

onki

User
Hallo Volker,

als Elektroniker ist mir schon klar, wie eStrom gemessen wird. Der Sensor hat auch prime funktioniert. Das Problem war die interne Referenz von 1.1V. Dadurch gab es negative Werte, die OTx nicht akzeptiert.
Problem ist somit gelöst. Degugmode lässt sich in der oxs_curr.cpp mit "#define DEBUGCURRENT" einschalten. Dadurch ist mir der Fehler dann aufgefallen, da die ausgelesenen Werte im Log ausgegeben werden.

Der Configurator ist nett, wirft aber mitunter unsauberen Code aus, der manchmal zu Problemen führt. Daher mache ich die Änderungen von Hand und speichere die Configs in entsprechenden Unterordnern ab.

Gruß
Onki
 

I3uLL3t

User
Hi zusammen,
Ich habe mir heute ein neues Vario gebaut mit einem GY-87. Eingestellt ist der vspeed auch auf Baro und IMU, meine Frage ist jetzt bringt es was zusätzlich noch ein zweites Büro anzuschließen oder wird das in der configuration mit IMU nicht mehr berücksichtigt?

Beste Grüße
 

kalle123

User
Hi

meine Frage ist jetzt bringt es was zusätzlich noch ein zweites Büro anzuschließen
Einfach machen und ausprobieren. (Büro, der war gut ;))

oder wird das in der configuration mit IMU nicht mehr berücksichtigt?
Schau in den oXs code rein. Wenn du da nicht mit klar kommst, wäre das eine Frage an den oXs Entwickler, nur der hat m.W. das Interesse an oXs verloren.

cu KH
 

Bernd Langner

Moderator
Teammitglied
Hallo

Ich bin auch mit oXs am basteln und habe mir mal die textdateien übersetzen lassen.
Hier der Abschnitt zu den Baro -Sensoren wichtig wäre ein Sensor wo du die I2C Adresse ändern kannst.

4.1 - Anschließen von 1 oder 2 barometrischen Sensoren (optionale Funktion) ************************************** ***********
* oXs können mit verschiedenen barometrischen Sensoren verbunden werden.
* Die besten Ergebnisse liefert der barometrische Sensor MS5611. Ein solcher Sensor wird normalerweise auf einer Platine (wie dem GY-63 oder dem GY-86) montiert, die über einen Spannungsregler 3,3 und einen I2C-Pegelumsetzer verfügt.
* Es ist jedoch möglich, eine Karte mit einem BMP085- oder BMP180- oder einem BMP280-Sensor zu verwenden (die billiger, aber weniger genau sind). Bitte beachten Sie, dass nur der erste Sensor ein BMP085, BMP180 oder BMP280 sein kann.
* Es ist möglich, 1 oder 2 Barosensoren anzuschließen; Der erste Sensor kann ein BMP085 oder BMP180 oder ein MS5611 sein. Der zweite muss ein MS5611 sein (da BMP085 und BMP180 nur eine I2C-Adresse haben).
* Hinweis: Wenn Sie einen Arduino mit 5 Volt Vcc verwenden, wählen Sie immer eine Baro-Sensorplatine mit einem 3,3-Spannungsregler und einem I2C-Pegelumsetzer.
* Jeder Sensor kann die absolute / relative Höhe (in Metern mit 1 Dezimalstelle) und die vertikale Geschwindigkeit (in Metern / Sek. Mit 2 Dezimalstellen) berechnen.
* Ein zweiter Sensor kann nützlich sein, da er, wenn er einer TEK-Sonde zugeordnet ist und die Option PPM verwendet wird, aus dem TX den Sensor auswählen kann, der die Variotöne erzeugt.
* Dies ermöglicht das Umschalten zB zwischen einem pneumatisch kompensierten und einem nicht kompensierten Vario.
* Wenn 2 Barosensoren verwendet werden, können OXs den Durchschnitt beider Sensoren als vertikale Geschwindigkeit übertragen. Dies scheint jedoch nicht sehr nützlich zu sein.
*
Gruß Bernd
 

I3uLL3t

User
Einfach machen und ausprobieren. (Büro, der war gut ;))
Da hat sich doch glatt die Autokorrektur eingeschlichen 😅


Danke Bernd im Grunde reicht der letzte Satz aus der description. Ich gehe auch mal ganz stark davon aus das durch die Nutzung von Baro und IMU das zweite Baro nicht mehr mit benutzt wird. Es gibt keine Definition im Code die ich gefunden habe wo er in entsprechende Funktionen springt. Nur Baro1 + Baro2 oder Baro1 + IMU.

Wie sind den eure Erfahrungen zu den Sensitivitäts Einstellungen? Hatte bei all meinen anderen das ganze jetzt immer auf Standard gelassen allerdings ist da schon ne deutliche Verzögerung zu höheren.

Wie verpackt ihr die Varios? Einfach stumpf Schrumpfschlauch oder dichtet ihr die noch weiter ab?

Grüße Marcel
 

kalle123

User
Hier ist noch eine Zwischenlage 'Luftfiltermatte' dabei.

Mach ich grundsätzlich bei den oXs Varios.



Gruß KH
 

Bernd Langner

Moderator
Teammitglied
Hi
Ich habe noch die nackte Platine aber die Idee von Kalle
leihe ich mir aus :D

Gruß Bernd
 
Hi zusammen,
Ich habe mir heute ein neues Vario gebaut mit einem GY-87. Eingestellt ist der vspeed auch auf Baro und IMU, meine Frage ist jetzt bringt es was zusätzlich noch ein zweites Büro anzuschließen oder wird das in der configuration mit IMU nicht mehr berücksichtigt?
Der zweite Baro-Sensor wurde aus drei Gründen eingeführt:
- korrekte Höhenanzeige bei Verwendung einer TEK-Düse am ersten Baro
- Umschaltmöglichkeit zwischen TEK (kompensiert) und normalem Vario (unkompensiert)
- Rauschverminderung durch gleichzeitige Auswertung beider Sensoren
der letzte Punkt hat sich aber in der Praxis als unnötig herausgestellt, die MS5611 Sensoren rauschen auch bei hoher Sensitivity weniger als befürchtet. In Verbindung mit IMU macht der zweite Sensor nur Sinn, um das IMU/Baro Vario mit dem reinen Baro Vario vergleichen zu können.
 
Zuletzt bearbeitet:
ich habe den oxs code für mich so modifiziert, dass beide baros gleichzeitig runter senden (frsky S.Port). Dann kann ich am Sender per schalter umstellen, ob tek- oder absolutvario mein gepiepse generiert. Hab ich inzwischen in 2 Fliegern erfolgreich im Einsatz.
 
ich habe den oxs code für mich so modifiziert, dass beide baros gleichzeitig runter senden (frsky S.Port).
Das geht ohne Codeänderung: #define FILL_TEST_1_2_WITH_VSPEED_AND_ALT_FROM_SECOND_VARIO
Dann kann ich am Sender per schalter umstellen, ob tek- oder absolutvario mein gepiepse generiert.
Das ist interessant, wie schaltest du die Vario-Quelle per Schalter um? Bisher kenne ich nur die Möglichkeit, im oXs per PPM oder S-Port umzuschalten.
 
Schöner workaround. Es ist immer gut, Alternativen zu haben. Ich finde die Lösung im Sensor trotzdem einfacher und besser. Die Variodaten kommen beim oXs am SPort sehr oft (bis 27 Hz bei einem Vario iirc) und je nach Anzahl der weiteren Sensoren bricht die Rate dann natürlich zusätzlich ein.
 
Habt Ihr bei den oXs mit 2x MS5611 keine Probleme mit extremen "Sprüngen" in den Vspd vom 2. Sensor?
Ich habe einen zusammengelötet und wenn ich beide Sensoren nutze habe ich große Abweichungen im Vspd beider. Immer nur einen Sensor aktiv, ist das Problem nicht da, die Sensoren kann ich somit ausschließen.

Gruß
Christoph
 
Ich hab nix derartiges gemerkt. Ich nehme halt die beiden Messwerte und schicke sie jeweils runter. Den Umweg über die defines in den configs gehe ich nicht. Vielleicht wird da was verunstaltet?
 
Oben Unten