Fräser taucht zu weit ein Estlcam / Winpcnc

Hi,
ich habe mal ne Frage bzgl. Estlcam / winpcnc usb. Und zwar fräse ich zu tief, so etwa 1mm.

Ich definiere in Estlcam 10mm Sicherheitshöhe und 3,2mm bei Z Zustellung und Frästiefe. Bei den Anbindungen gebe ich komplette Höhe an. Soweit sogut.

Im Winpcnc habe ich beim Werkzeug überall 0 stehen weil die Parameter stehen ja im .din. ich lade das .din und fahre meinen Nullpunkt x/y/z am Werkstück an und speichere die Koordinaten.

Ich versteh jetzt nicht, warum er durchgängig zu tief eintaucht, die Anbindungen fräst er mir auch 1mm weg. Im .din steht auch alles richtig drin:
Code:
G00 Z-0.5000
G01 Z3.2000 F300 S24000
Und die Platten lagen plan auf der Opferplatte.
Daher vermute ich eher, dass beim Winpcnc was nicht richtig konfiguriert ist.

Gestehe, ich bin totaler Anfänger was CNC Maschinen angeht.
Welchen Parameter überseh' ich, kann mir da jemand auf die Sprünge helfen?

Trotzdem war ich froh die 20 Rippen überhaupt gefräst zu bekommen. Das blöde ist auch die Maschine (Mecha Plus) steht nicht bei mir und ich komm da einfach zu selten ran um damit zu spielen und so alles mal in Ruhe auszuprobieren.

Viele Grüße, Andreas
 
Fehler in Z-Richtung quantifizieren ..

Fehler in Z-Richtung quantifizieren ..

Ciao Andreas

Da Du bisher keine Antworten erhalten hast, im Folgenden meine bescheidenen Kenntnisse und mögliche Fehlerquellen.
Ich benutzte WinPCnc-USB und Estlcam V8.

Vorausgesetzt, Du hast kein mechanisches Problem, gibt es verschiedene Möglichkeiten, wieso Dein Fräser zu tief geht. Allerdings solltest Du auch abklären, was Du mit zu ‘tief‘ meinst. Eventuell hast Du da einen systematischen Fehler drinn mit einem Faktor 1.x, damit könntest Du die Fehlersuche bei den Parametern im WinPC eingrenzen. Ist der Fehler (zu tief) immer absolut gesehen der gleiche, oder variiert dieser mit zunehmender Werkstücktiefe ( konstanter variabler Fehler?).

- Stimmen die Zustellungen in der Definition des Fräsers ?
- Saubere Z=0 auf Oberflächen Definition bei der Definition des Werkstücknullpunktes (X/Y/Z) ?
- Bei der Definition im Estlcam ‘stimmt‘ die Eingabe der Werkstücktiefe und der anderen Parameter (Zustellung, Anbindungen Länge/ Tiefe) ?
- Sind die Parameter für die Masseinheiten bei Estlcam und WinPC die gleichen ?
- Taucht der Fehler erst mit der Zeit auf, z.B Schrittverluste in Z-Richtung ?

Versuche den Fehler in Z-Richtung zu quantifizieren – auch abhängig verschiedener Werkstück-Dicken, dann können Dir hier die Profis sicherlich helfen. Fräse mal gleiches Bauteil, z.B 2mm/ 4mm/ 6mm/ 8mm dick und versuche die Fehler darzustellen ..

Viele Grüsse,
Oliver
 
Hi Oliver,
danke für deine Antwort.
Der Fehler ist absolut, d.h. er fräst durchgängig zu tief -> die Tiefe ist immer die gleiche ob an der Anbindung oder in der Opferplatte. Estlcam kann ich *eigentlich* ausschließen, der Gcode ist ja eindeutig. Trotzdem mal ein Screenshot der Parameter im Estlcam:
estlcam.JPG



Zu Winpc:
Screens kann ich grad keine machen, da ich nicht bei der maschine bin. Aber soviel kann ich sagen:
XYZ Nullpunkte sind sauber definiert, in XY Richtung passt die Fräsung sehr exakt. Und die Maßeinheiten sind in beiden Programmen gleich definiert (sonst würde es in XY-Richtung ja auch nicht passen).

Bin ein wenig ratlos :confused: die Maschinenparameter haben wir gemeinsam mit dem Hersteller am Telefon eingetragen.

Und hätten wir Schrittverluste, dann müsste es ja mit der Zeit schlimmer werden oder?

Ich werde bei Gelegenheit mal ein paar Probestücke fräsen und Fotos machen. Das ist eine gute Idee.

Viele Grüße, Andreas
 
Moin
Gleich in deinem ersten Post steht im Gcode G00 Z-0.5 Dh die Fräse fährt mit G0 ins Material 0.5mm tief. Im nächsten Satz steht G01 Z3.2 dh die Fräse zieht mit Fräsgeschwindigkeit den Fräser auf 3.2mm aus dem Material. Eigenlich sollte da stehen G00 Z0.5 und dann G01 Z-3.2 . Es kann sein das du im WinPcnc deine Z Achse invertieren musst.
mfg Hermann
Ps: Poste mal den Code komplett dann lass ich ihn im Mach 3 laufen.
 
Ich interpretiere den Code so:

G00 Z-0.5 :: Positioniere 0,5mm über Z=0
G01 Z3.2 :: Eintauchen auf 3,2mm

Auf der Fräse ist Tiefe > 0 und Höhe < 0

Gcode hab ich in die Dropbx gelegt, kannst du gerne mal angucken. Vielleicht musst du aber die Z Achse in deinem Mach3 invertieren, falls die Richtungsangaben bei dir andersrum sind als oben beschrieben:
https://dl.dropboxusercontent.com/u/2730815/R5uR6.din


Danke und viele Grüße,
Andreas
 

TinoE

User
Hallo Andreas,

es gibt - wenn ich mich richtig erinnere - in WinPCNC eine Einstellung mit der ein "-" im G-Code als "+" interpretiert wird und natürlich umgekehrt. Somit führt Z dann bei "-" ins Werkstück, nicht bei "+". Dann muss aber evtl. die Drehrichtung Z geändert werden.

Eine ganz banale Frage, die Einstellungen der Steigung für die Z-Achse stimmen?
Bist du sicher, dass es immer absolut der gleiche Fehler ist? bei 3mm Materialstärke in Holz fällt ein kleiner Unterschied nicht sofort auf.

Wenn es bei einer Frästiefe von 1mm eine Abweichung von 0,8mm sind und bei 3mm Frästiefe eine Abweichung von 1mm dann fällt das nicht sofort auf.

Gruß

Tino
 

TinoE

User
dein G-Code sagt aber was anderes.

G00 Z0.5000 Positionierung
G01 Z-3.200 Eintauchen

Das passt so.

(Nr. 1: Ausschnitt 8)
G00 X44.8529 Y31.6439 - Positionieren
G00 Z0.5000 - über's Werkstück
G01 Z-3.2000 F300 S24000 - Eintauchen
G02 X46.8284 Y33.6437 I1.9917 J0.0081 F600 - Kreis oder Kreisabschnitt
G02 X48.1704 Y30.1426 I0.0192 J-2.0004 - Kreis oder Kreisabschnitt
G02 X44.8529 Y31.6439 I-1.3214 J1.4963 - Kreis oder Kreisabschnitt
G00 Z10.0000 - Raus aus dem Werkstück auf 10mm über Werkstück

Fahre mal manuell und messe ganz pragmatisch mit einer Schieblehre.
 
Moin
0 ist die Oberfläche des Werkstücks. Z Hoch ist +. Z- ist ins Werkstück.Ich kann mich irgendwo dunkel erinnern das bei Pcnc evtl auch bei Winpcnc für Gcode die Z Achse invert. werden muss.Einfach mal in die Einstellungen von Win Pcnc schauen
mfg Hermann
Ps Tino war erheblich schneller
 
Also die Z Achse ist inveriert sprich rein ins Material ist hier positiv, nach oben weg vom Material ist hier negativ. Sonst würde er ja auch 10mm ins Werkstück reinfahren (auf Sicherheitshöhe), wenn die Richtungen nicht passen würden bzw. nur o,5mm tief fräsen und dann in 3.2mm ne Luftnummer fahren.

Das dumme ist, wie gesagt, die Maschine und der Rechner stehen nicht hier. Ich werde mal die eingestellte Steigung prüfen. (Die Maschinenparameter haben wir damals mit dem Hersteller am Telefon eingetragen. Es sollte schon stimmen.)
Und wie gesagt mal ein paar Referenzfräsungen vornehmen in verschiedenen Höhen, um den Fehler zu präzisieren.
Das sind ja schon mal brauchbare Hinweise! Danke soweit dafür.
Gruß Andreas
 
Moin
Invertiere unter Datenformate die Z Achse,so das sie bei - ins - also Werkstueck und bei + nach oben fährt.wenn da invers steht und sie trotzdem anders rum fährt musst du den Motor umklemmen .
MFG Hermann
PS: Wenn die Achse falsch rum fährt suchst du den Fehler noch in 3 Jahren.
 
Schliesse mich meinen Vorgängern an. -Z ist immer in das Werkstück und +Z immer aus dem Werkstück raus. Das muß erst mal stimmen sonst gibt das nix.

Zudem achte in Winpcnc mal drauf wo Du die Z Achse genullt hast. Werkstück Oberseite oder Werkstück Unterseite. Das ist in Winpcnc aus meiner Erinnerung heraus nämlich auch noch so ein kleines Thema....
 
Hallo,

-Z ist immer in das Werkstück und +Z immer aus dem Werkstück raus.

  • Das ist zwar allgemein üblich und die mit weitem Abstand häufigste Variante - nur leider ist es nicht immer korrekt.
  • Das Koordinatensystem von WinPC-NC läuft standardmäßig "andersherum" - entsprechend vertauscht Estlcam die Vorzeichen sobald WinPC-NC ausgewählt wird.
  • Das Fehlerbild wäre ein anderes wenn das hier der Grund für das Problem wäre.

WinPC-NC hat recht viele Einstellmöglichkeiten - u.a. dass die Frästiefen nicht aus dem CNC Programm übernommen werden sondern durch die Werkzeugliste in WinPC-NC bestimmt werden.

Ich würde mal folgendes probieren:

  • Pausiere das Programm sobald der Fräser runtergefahren ist und schaue was die Koordinatenanzeige von WinPC-NC sagt. Stimmt die nicht mit dem CNC Programm überein ist es auf jeden Fall eine Einstellungssache in WinPC-NC...
  • Prüfe vor Programmbeginn ob Z0 auch tatsächlich genau auf der Werkstückoberfläche ist...
  • Deinstalliere ggf. WinPC-NC und installiere es nochmal neu falls die Einstellungen total zerschossen sein sollten...
 
Moin
Dann hätte er aber den falschen Post gewählt
[QUOTETinoE]
dein G-Code sagt aber was anderes.

G00 Z0.5000 Positionierung
G01 Z-3.200 Eintauchen

Das passt so.

(Nr. 1: Ausschnitt 8)
G00 X44.8529 Y31.6439 - Positionieren
G00 Z0.5000 - über's Werkstück
G01 Z-3.2000 F300 S24000 - Eintauchen
G02 X46.8284 Y33.6437 I1.9917 J0.0081 F600 - Kreis oder Kreisabschnitt
G02 X48.1704 Y30.1426 I0.0192 J-2.0004 - Kreis oder Kreisabschnitt
G02 X44.8529 Y31.6439 I-1.3214 J1.4963 - Kreis oder Kreisabschnitt
G00 Z10.0000 - Raus aus dem Werkstück auf 10mm über Werkstück[/QUOTE]
mfg Hermann
 
Das Problem der Z Achse hatte ich auch .
Es ist wie Hermann schreibt .
Minus muss nicht nach Unten bedeuten auch wen Minus eingestellt ist .
 
Hi,

Blöde Frage, wenn es eine Frage der Invertierung der Achsen wäre, dann hätte Andreas doch gar keine Teile fräsen können ? Die nächste Frage wäre dann, wie aufgrund einer falschen Z-Richtung der konstante Tiefenfehler erklärbar wäre ?

Müsste es nicht möglich sein, mit der Funktion ‘Manuelles Fahren‘ mal verschiedene Tiefen ab z.B einer fiktiven Oberfläche (Klötzchen, z.B 20mm hoch in Nähe Nullpunkt (x/y) mit Doppelklebeband befestigen und manuell verschiedene Tiefen ‘abzufahren‘ (vorgängig natürlich ‘Speichern x/y/z‘ drücken) und messen wie tief der Fräser wirklich fährt – natürlich gleichzeitig auf Display schauen was beide Koordinaten (Maschinenkoordinaten/ Werkstück-Koordinaten) machen? Notfalls Klötzchen dann noch Diagonal in gegenüberliegende ‘Ecke‘ des Arbeitstisches nochmals anbringen und wiederholen ? Interessant wäre dann, inkl. Vorzeichen, z.B im 5mm Tiefenschritten was gemessen (IST-Wert Z) und was Display/ Anzeige anzeigt.

Man könnte auch ein Mini G-Code Programm schreiben, dass jeweils in 5mm Schritten in Z-Richtung fährt, kurz verharrt (Tiefenmessung), dann wieder auf Sicherheitshöhe/ Oberfläche geht, im weiteren +5mm noch tiefer fährt usw. usf. Man muss ja keinen Fräser einspannen (Verletzungsgefahr), irgendein Stift der in die Fräseraufnahme passt, reicht auch aus. Man hätte dann, für verschiedene Z-Tiefenzustellungen die IST- und SOLL-Eintauchwerte in Z-Richtung. Würde man nun das Gleiche durch Estlcam erstellen (G-Code: Punkte im Abstand weniger [mm]), dann könnte man die wesentlichen Programmzeilen (im G-Code) miteinander vergleichen (Eigenprogrammierung vs. CAM-Ausgabe).

Zeigen der eigene G-Code für den Frästiefenversuch und Estlcam gleiche Vorzeichen und absolute Tiefen, dann müsste der Fehler in der absoluten Tiefenzustellung eigentlich von irgendeiner Parameter-(Ver-)-Wahl im WinPC-nc stammen ? Vielleicht tritt der Fehler ja auch erst ab einer bestimmten Tiefe 'sprunghaft' auf ?

@Andi: anbei ein paar Schreenshot meiner WinPC-nc (USB) und Estlcam-Einstellung. Allerdings nicht vom Rechner, den ich zum Fräsen nutze, sollte allerdings praktisch das Gleiche sein.

Ich wünsche Allen ein schönes Wochenende,
Oliver
 

Anhänge

  • Manuelles Fahren und Tiefenmessung.png
    Manuelles Fahren und Tiefenmessung.png
    38,8 KB · Aufrufe: 159
  • Estlcam.jpg
    Estlcam.jpg
    64,7 KB · Aufrufe: 138
  • Koordinaten.png
    Koordinaten.png
    17,3 KB · Aufrufe: 100
  • Datenformat_WINPCnc.png
    Datenformat_WINPCnc.png
    22,6 KB · Aufrufe: 104
  • Maschine.png
    Maschine.png
    22,2 KB · Aufrufe: 95
  • Sonstige.png
    Sonstige.png
    24,9 KB · Aufrufe: 98
Ich hab einen Hacken bei Z Achse Invetieren .Keine Ahnung ob das einen Unterschied macht .
Parameter Maschine und Koordinaten hatte ich damals einen Fehler mit der Z Achse .
Irgendwie ging die nur einen Teil ins Minus ,danach nach oben .

Was für eine Version PCNC hast Du ?
Da steht was mit Plasma .
 
Evtl. habt ihrs ja überlesen aber ich schrieb bereits das es in winpcnc extrem wichtig ist zu sagen wo die Werkstückoberfläche liegt. Oben oder unten am Werkstück.

Je nach Materialdicke kann man so "Luftfräsungen" erzeugen oder auch mal eben mit dem Fräser 5mm ins Material fahren. Extrem ärgerlich bei 1,5mm Fräsern. DA machts nämlich einfach "plick" und weg sind die. Das gepaart mit dem falschen "Z" Vorzeichen und schon hat man abenteuerliche Frästiefen...

Es ist aber einfach zu lange her. Ich habe mich irgendwann von der gruseligen Winpcn Logik verabschiedet und Mach3 gekauft. Seitdem bin ich solche Sachen los....

Grüsse
Andreas
 
Hallo zusammen, ich wollte euch noch Rückmeldung geben. Hab den Haken bei Z-Achse Invertieren rausgenommen. Auch beim Estlcam. War quasi alles doppelt invertiert :) Nun passt das Vorzeichen.
Dann verschiedene Höhen manuell angefahren und überprüft - auf dem gesamten Verfahrweg der Z Achse. Alles passt nun. Hab auch gleich paar Urmodelle für Servoabdeckungen gefräst. Hat super geklappt.
Auf jeden Fall war heute alles maßhaltig.

Vielen Dank für die Ratschläge und die Mühe mit den Screenshots! :)
 
Ansicht hell / dunkel umschalten
Oben Unten