DJI NAZA mit anderen BEC betreiben?

knzin

User
Hallo.

Ich habe den F450 von DJI NAZA und der fliegt sehr gut.
Jetzt habe ich mir einen anderen Copter aus Einzelkomponenten gebaut. Ich habe die NAZA programmiert; bei den Reglern (ohne Optokoppler) habe ich den Plus-Stecker rausgezogen und isoliert.

Die Regler habe ich vorher ganz normal mit einer Fernsteuerung programmiert. Die Motoren laufen alle an, wenn man den Gasknüppel nach vorne schiebt.

Jetzt, an der NAZA (ohne Plusleitung) laufen die Motoren einfach nicht an. Ich habe nach der Programmiertung alles wie beim F450 gemacht: beide Knüppel nach rechts/unten (z. B.), dann das Gas auf 50%. Trotzdem ist kein Motor angelaufen.

Was könnte ich da machen?


Bis dahin.
Knut
 
Hi Knut

Ein anderes BEC zu verwenden macht meiner Meinung nach keinen Sinn, du brauchst ja das DJI BEC als USB Schnittstelle und die LED zur Zustandsanzeige.
Aber was lässt dich darauf schliessen das ein anderes BEC die Lösung für dein Problem wäre? Misst du keine Spannung am DJI BEC?!

Was macht die Status LED beim einschalten? geht sie die Blinksequenzen durch und meldet dann bereit?
Hast du das Board über die Software parametriert?
stimmen die Servowege?
Das DJI Naza schaltet nicht frei wenn z.B. die Steuerknüppel beim einschalten nicht in Mittelposition (bzw. beim Gas die min. Pos.) befinden, also wenn du z.B. die Trimmung betätigt hat?

Gruss Mathias
 
Regler ohne opto-Koppler

Regler ohne opto-Koppler

Hallo shoggun.

Da habe ich mich wohl falsch ausgedrückt.
Die BEC-Versorgung der NAZA ist natürlich noch dran.
Die Regler für die Motoren sind nur ohne Optokoppler. Deshalb hatte ich die +-Leitung aus den Steckern gezogen, nachdem ich die Regler/Motoren mit einem anderen Sender/Empfänger erstmal laufen lassen habe.

Die Status-LED blinkt orange.

Mit dem Board/der NAZA habe ich nichts gemacht.

Beim Einschalten sind alle Knüppel in Mittelstellung, außer der Gasknüppel. Dann bewege ich beide Knüppel nach rechts-unten. Dann müßten eigentlich die Motoren anlaufen.

Ich habe noch einen F450-Copter mit den Original-Opto-Reglern von DJI. Da funktioniert alles einwandfrei.
Ich wollte mir nur einen größeren Copter bauen und habe dazu Regler ohne Opto-Koppler gekauft.

Danke einstweilen. Vielleicht fällt dir was ein, was mir helfen könnte.
Bis dann.
Knut
 
Hallo Knut

Das kann durchaus an den Reglern liegen.
Es gibt Regler die erwarten gleich nach dem anstecken des Akkus
ein gültiges Signal von Sender.
Fehlt das schalten Sie auf sturr
Für diese Regler braucht die Naza einfach zu lange zum booten.

Gruß Friedhelm
 
Regler ohne Optokoppler

Regler ohne Optokoppler

Hallo Friedhelm.

Der Link ist sehr interessant und hört sich an, als ob er mir helfen kann.

Ich probiere es nachher mal aus und sage hier Bescheid.
Evtl. hätte ich auch die Regler mit demselben Sender programmieren sollen, mit dem ich dann den Copter fliege. Ich habe die Regler aber mit einer 40MHz Grpn.-Anlage programmiert. Da könnte es sein, daß die Gaswege oder alle Knüppelwege etwas kürzer sind. Wer kommt denn auf so was?

Bis dann.
Knut
 
Regler ohne Opto

Regler ohne Opto

Ich habe jetzt alle Regler mit der 2,4GHz-Fernsteuerung programmiert, mit der ich dann auch den Copter fliege.
Dann habe ich alles an den PC gehängt, die Knüppel nochmal auf Vollausschlag geeicht, Richtung überprüft und alles so gemacht, wie beim F450.
Nach Beendigung der Prozedur habe ich den Copter in Betrieb genommen - die Motoren bewegen sich nicht.

Sollten etwa die Regler auf STUR schalten, weil die NAZA zuerst ein paar Sekunden braucht, um zu initialisieren! Da hat in einem anderen Forum einer den Vorschlag gemacht, die Regler über ein Y-Kabel anzustecken, damit man sie nach der Initialisierung erst anstecken kann.
Sollte ich das mal probieren?

Bis dann.
Knut
 
Regler ohne Opto - ES FUNKTIONIERT!!!

Regler ohne Opto - ES FUNKTIONIERT!!!

Hallo an alle, die sich die Mühe gemacht haben, mir zu helfen.

Der Tipp von Friedhelm (buma) im RC-Line-Forum, in dem der Hans-Willi von Stein-Elektronik beschrieben hat, wie das mit einem Y-Kabel zu machen ist, hat funktioniert.
Die Motoren lassen sich nach einer CSC einwandfrei starten.
Es ist offenbar so, daß die NAZA zu schnell ist - oder die Regler zu langsam sind. Dann schalten sie auf OFF und nichts geht mehr.
Wenn man die Regler nach dem Inizialisieren durch die NAZA nochmal absteckt und nach ca. 1 s wieder ansteckt, funktionieren sie einwandfrei.


Ich hatte die Regler nochmal mit einer Programmierkarte programmiert:
b04.jpg

So sieht es aus, wenn die Regler in der NAZA stecken. Natürlich werden die freien +-Kabel noch isoliert! Ich hatte sie bloß so frei hängen lassen, weil ich ja öfter mal die Regler normal an einen Empf. stecken wollte.
b06.jpg
 
Hi,

wir hatten ja heute per PN Kontakt, das Problem hatten wir bisher nur bei den alten Gaui Reglern.
Vielleicht ja mal den Hersteller/Vertreiber nennen, dann haben die anderen da auch was von.

Gruss
Hans-Willi
 
Copter mit Nicht-Opto-Reglern

Copter mit Nicht-Opto-Reglern

Heute habe ich den neuen Copter geflogen - problemlos!
Der Trick mit dem An- und Abstecken der Regler funktioniert einwandfrei und der NEUE liegt mit den 10x4,5" Props wie ein Brett und reagiert auch sehr gut aufs Gas.

Mit der NAZA-Regelung kann also jeder, sogar ein Flächenflieger wie ich, einen sehr guten Quadrocopter bauen, der sich auch leicht fliegen läßt.

Mal sehen, wie sich ein Y oder HEX fliegt.

Bis dahin.
Knut
 
Tach zusammen

hab jetzt auch ein sehr wahrscheinlich ein Anfänger Problem

mein Naza ist angeschlossen soweit alles klar

das Haupt Problem ist jetzt wenn ich gas gebe fangen nicht alle vier zu laufen sondern nur einer bei 10% bei 20 % 2 Motoren u.s.w
wie kann ich das gas anlernen mein regler ist der Hobbywing 20A Skywalker Quattro 20Ax4 UBEC 4 in 1 20A Brushless ESC


wäre toll wenn ich hiefe bekommen würde

danke im voraus
 
Moin, hat der Chinese kein Handbuch dabei gelegt oder hast Du vielleicht eine Allergie gegen Anleitungen...;)

Scherz beseite

Versuch das mal..ich denke mal die Firmware ist bei allen Versionen des Reglers gleich.

Für jeden Eingang gesondert durchführen !!!!!!!!Und auch alle Programmierungen wie Bremse aus, Timing etc. müssen für jeden Eingang gesondert gemacht werden.

Gasweg einlernen..
- Sender auf Vollgas und Einschalten
- Akku an den Regler anstecken (Bitte jemanden bitten den Copter fest zu halten, für den Fall der Fälle)
- 2 Sekunden warten
- Doppel Beep bestätigt die Erkennung der Vollgasstellung
- Gasknüppel zurück auf Leerlauf
- Es kommen mehrere Beep Töne (Anzahl der Zellen)
- Ein langer Beep Ton erfolgt, jetzt ist der Gasweg erkannt.

Akku abstecken und nächstes Regler kabel an den Empfänger anstecken und alle anderen Eingänge ebenso einstellen.

Ich hoffe bei dem Regler liegt nicht auf jedem Servostecker eine BEC Spannung an. Dann mußt die alle roten Adern der Servoleitungen auftrennen.
Die Naza hat ein eigenes BEC, was nicht parallel zu anderen BECs betrieben werden sollte.
 
Regler beim Copter

Regler beim Copter

Hallo Tropi69.

Weiter oben habe ich ein Foto von der Programmierkarte drin, wie ich die Regler (jeden einzeln) programmiert habe. Es geht auch mit dem Sender, wie Stein gerade geschrieben hat. Die rote Plus-Leitung hast du ja aus den Steckern gezogen, oder?

Dann könnte evtl. noch ein Fehler beim programmieren der NAZA am PC passiert sein. Sind alle Knüppel auf Vollausschlag gegangen (grüne Schieber)?

Bei mir hat es, wie oben beschrieben, funktioniert. Und ich hatte SkyWing-Regler. Lies einfach nochmal kurz durch, was da steht.

Viel Glück, obwohl das Gelingen eigentlich nichts mit Glück zu tun hat, alles Technik.
Knut
 
Ansicht hell / dunkel umschalten
Oben Unten