OpenTx - Radiomaster TX16s - Welche Empfänger?

ASW29

User
Kann man eigentlich das MPX M-LINK HFM4 Modul für die TX16s als externes Modul verwenden? Habe hier mal die Seiten überflogen, aber nichts gefunden.
Gruß
Dirk
 

onki

User
Hallo,

sofern du es in ein Gehäuse einbaust und Versorgungsspannung wie auch PPM-Signal vom Modulstecker auf das Modul führst, steht dem nichts im Weg.
Dem µC ist es ziemlich egal, was für ein nachgeschaltetes Modul verwendet wird. Nur die Polung des PPM-Signals muss stimmen und die Betriebsspannung passen.
Das MPM kann seit ein paar Tagen aber auch MLink (siehe Links weiter oben).

Gruß
Onki
 

onki

User
Hallo Dirk,

OTX hat nur wenig mit der Multiprotokoll-Firmware zu tun.
Für die MLink-Funktionalität ist einzig die MPM-Firmware verantwortlich:


Bevor du mit derm HFM4-Basteleien anfängst, würde ich das erst mal mit der MPM-Firmware versuchen. Zumal damit auch Telemetrie möglich zu sein scheint, was ansonsten einen externen Protokollumsetzer benötigt.


Gruß
Onki
 

ASW29

User
Onki,
gibt es dafür denn auch eine Beschreibung der Installation und Näheres zur MPM. Ich habe meine TX16s noch nicht so lange und bin da nicht so firm.
 

onki

User
Das ist so einfach, das man keine wirkliche "Anleitung dazu braucht.

Einfach die für deinen Steuermodus nötige Firmwaredatei herunterladen.

Ich fliege Mode1 (RETA - Seite-Höhe links; Gas-Quer rechts) dehalb brauche ich diese hier:


Die Datei dann in den /Firmware-Ordner der SD-Karte des Senders kopieren, danach auf "SYS" drücken und im Dateibrowser diese Firmware-Datei anwählen. Im aufkommenden Dialog dann "flash int. Module" wählen und den Programmiervorgang abwarten.

Danach kannst du das Protokoll in den Moduseinstellungen des Modells einstellen. Einfach MLink aus der Liste der Protokolle auswählen.

Es ist sicher empfehlenswert auch die OTX-Version aktuell zu halten.

Gruß
Onki
 

ASW29

User
Fliege ja auch Mode 1. Habe OTX 2.3.10 drauf. Funktioniert das damit oder muss ich erstmal auf die neueste 2.3.11 updaten?
 

onki

User
OTX 2.3.11 war vor der aktuellem MPM-Firmware veröffentlicht.
Von daher ist diese nicht zwingend nötig aus meiner Sicht. Hab es aber nicht probiert, da ich die .11 schon drauf hatte.

Gruß
Onki
 
Hallo zusammen, also das Multiprotocol v1.3.2.30 mit dem M-Link Protokoll geht zumindest auf meinen zwei IrangeX Modulen ("JR groß und XLite klein") , aber die M-Link Telemetrie (funktioniert nicht wirklich bei mir) und ist da noch weit entfernt von meinem HFMG3 mit dem Arduino Konverter und passender Software von Reinhardt in meiner Radiomaster TX16S .
Da müssen schon noch diverse MPM Upgrades erfolgen bis das gleichermaßen funktioniert. Nichts desto trotz eine super Entwicklung nur mal am Rande.
Ich fliege meine RM TX 16S daher weiterhin mit dem HFMG3 und da sollten eigentlich alle M-Link Module in gleicher Weise funktionieren. Das bekommen der M-Link Module auf dem Markt ist halt das Problem 😢 daher wäre halt eine gleichwertige MPX M-Link Softwarelösung mit gleichzeitiger funktionierender Telemetrie im MPM der Hit.
Grüße
Wolfram
 

ASW29

User
@ Onki
Danke, werde das dann die Tage mal probieren.

@Astor 87
Ist mir mit der Telemetrie momentan nicht so wichtig.Kann aber erstmal meine MPX Empfänger nutzen. Schön wäre es wenn mal ein Update kommt, um die Telemetrie voll zu nutzen. Habe ja leider nur das HFM4 in meiner alten EVO9 und keinen Schimmer, wie man dort Antenne und Bind-Taster anbringt.
 
Hallo Dirk
beim HFM4 was für das interne EVO Update auf 2,4Ghz gedacht ist, ist die Antenne ja direkt dran, müsste man nur halt einen Halter Adapter machen. Binden: das ist wohl ein Problem, das kann ich leider auch nicht so beantworten, da sind vielleicht auf der Platine die entsprechenden Pin Abgriffe wie bei den anderen externen MPX Modulen da, aber es war ja als direktes HF für die EVO gedacht, nicht ppm....sorry ... vielleicht kann das Forum da weiter helfen.
Good Luck
Wolfram
 

ASW29

User
Hallo Wolfram,
der Antennenabgriff befindet sich aber nicht am HFM Modul selber, sondern auf der Senderplatine. Ob der aber zu einem der Pin's des HFM Modul geht entzieht sich meiner Kenntnis.
Vielleicht findet sich hier noch jemand, der das Problem mit dem "Binden " lösen kann.
 

mannikla

User
Hallo Dirk,
kannst du bitte mal ein Bild einstellen von deinem Antennenanschluss auf der Senderplatine?
Der Anschluss der 2,4 Ghz Antenne müsste auch auf der HFM4 Platine sein.
Ich bau mit diversen M Link Modulen meine alten Retro Sender um und konnte deshalb bisschen vergleichen und meine Neugierde stillen.
HFMx und HFM4 Platinen sind nahezu identisch.
HAb mal ein Bild dazu - nicht davon täuschen lassen, weil das Antennenkabel unter die HFM4 Platine läuft.
HFM4 Binde Option.jpg


HFM4 Modul abgezogen Rückansicht:

HFM4 Ant. Anschl..jpg


Der HF Anschluss mit dem Goldkontakt Verbinder auf dem MLink Modul ist bei allem M Link Modulen der Gleiche. Unterschiede gibt es nur am nachfolgenden Antennenkabel.
Achtung - wenn das bei dir anderst aussieht - dann weiss ich nicht welches Modul bei dir eingebaut ist - das heisst - meine nachfolgende Aussage stimmt möglicherweise nicht.

Anschluss von Bindetaster und BindeLED:
Zum Vergleich ein Bild einer HFMx v1 Platine mit Bindetaster und LED auf der Platine:
HFMx v1.jpg


Jetzt vergleiche mit dem Bild ganz oben - auch da sind unter dem HFM4 Aufkleber die Lötpads für Bindetaster und LED vorhanden.
Um einen externen Bindetaster mit Kontrolleuchte anzuschliessen, kannst du die 3 Lötaugen links neben den Lötpads mit einer 2,54 mm Stiftleiste bestücken.
Anschluss über ein normales Jr Servokabel. Belegung:
Lötauge unten - schwarz
mitte - rot
oben - gelb

Da passt dann der originale MPX Bindetaster dran.

Belegung vom Bindetaster - schwarz - geht auf Taster und auf Masse der LED
rot - auf Plus der LED
gelb auf den zweiten Pin vom Taster.

Gruss Klaus

PS: Tante Edith meint ich sollte noch dazu schreiben - man sollte Löten können und auch das passende Werkzeug haben.
Das Lötauge vom Masse Pin führt unheimlich stark die Wärme ab. Mit einem 10 Watt Lötkolben mit feiner Nadelspitze bekommst du nicht genugend Wärme schnell genug übertragen. Das wird nix. Zur Sicherheit sollte das jemand löten, der ein vernünftiges Lötwerkzeug und Erfahrung damit hat.
 
Zuletzt bearbeitet:

ASW29

User
Hallo Klaus,
du hast recht, das Antennenkabel ist am Modul. Hatte wohl nur ein wenig oberflächlich hingeschaut.
20210214_115621.jpg
 

ASW29

User
Wenn das HFM4 Modul aber wegen des Datenprotokolles nicht funktioniert, kann man das wohl vergessen. Löten wäre bei mir übrigens nicht das Problem.
Wollte noch ein zweites Bild anhängen, geht aber nicht.
 

mannikla

User
HAllo Dirk,
ich kenne die RM 16 TX nicht wirklich - interessiert mich auch nicht.
Aber...
in #90 schreibt Wolfram:
Ich fliege meine RM TX 16S daher weiterhin mit dem HFMG3 und da sollten eigentlich alle M-Link Module in gleicher Weise funktionieren.
Also muss die RM 16 auch das PPM bereitstellen, sonst würde das HFMG3 nicht funktionieren.
Gruss Klaus

PS: ich hab das mit dem MPM ( was immer das sein mag ) noch nicht eingelesen, verstehe das aber so, das ein entsprechendes Fremd HF (Multiprotokoll Modul) über eine entsprechende Software ein MLink Signal protokoll erstellen kann.
Finde ich genial. da es irgendwann wohl keine MLink Hf Module mehr geben wird, ausser auf dem Gebrauchtmarkt.
 

ASW29

User
Hallo Klaus
MPM ist die Firmware,welche man auf den Sender überträgt. Damit ist es dann möglich, über das interne Multiprotokoll-Modul die MLink Empfänger zu steuern. Die Telemetrie scheint damit aber wohl nicht richtig zu funktionieren. Dieses soll bei Einbau eines MLink Modules wohl anders sein.
 
Oben Unten